MSP430-JTAG-TINY-V2 Windows 10 "cannot connect"

Started by dteich, May 18, 2016, 08:57:51 PM

Previous topic - Next topic


I am running the Olimex application as a stand alone programmer (not IDE or IAR environment).

I have followed the directions for installation of the drivers.  I disabled the signature requirements and went to the Device manager.  However, unlike you screenshot, I can only see the device under Ports > USB Serial Device (COM3).  When I try and change the driver it tells me that the existing driver is the better one.

Bottom line -- I still get the "can not connect to the programmer" error message.



MSP430-JTAG-V2 should work properly under Windows 10. I use Windows 10 also and it seems to work fine here. You are possibly facing an issue related to the driver installation (probably you would need to manually point to the older driver as described in 2.). Consider the following steps:

1. The drivers that we provide are not digitally signed. In order to install the drivers you need to disable temporarily the driver signature enforcement, then install the driver for the debugger. The next time you restart your computer the driver signature enforcement would turn on automatically again which ensures that your system is not vulnerable to software threats. The good news is that you don't have to install the driver again (as long as you use the same USB port). There are a lot of guides and videos available online that show how to disable "driver signature enforcement" in Windows 10.

2. Ensure you are using the drivers provided by Olimex. These are located in the archive here:

Note that it is possible to have multiple drivers associated with the same hardware. Windows would select the newest one with regard to the release date (but the newest one is not always the properly working one). In this case you would need to manually revert to the version from the archive. Generally, when there are a number of drivers suitable for a specific of hardware you can switch manually between them:

a) Make sure that "Driver Signature Enforcement" is disabled before switching the the unsigned drivers.
b) Open "Windows Device Manager"
c) Right-click over "USB Serial Device (COM x)"
d) Select "Update Driver Software..."
e) Select "Browse my computer for driver software"
f) This time select the bottom option "Let me pick from a list of drivers on my computer"
g) Select the driver with "Olimex" name in it.
h) Select next and close the window.

3. Make sure to copy-paste the latest dlls suitable for MSP430-JTAG-TINY-V2 in the installation folder of Olimex MSP430 Programmer software (olimex.dll should be version These dll files can be found in the archive with the drivers. After that when you launch the software and attempt to perform an operation you may be asked to update the firmware – agree to do so.

4. Avoid using USB 3.0 ports or try with an USB hub. Avoid long USB cables. Test with another cable and computer if possible.

Best regards,
Technical support and documentation manager at Olimex


Thanks for the help.  I was able to program properly.  Then I rebooted the PC to return to the signed driver protection.  Now the programming hangs up -- but no connection error message.

The status shows "initializing", and that is where it hangs up.

Here are the drivers and dlls that I use:

MSP430.dll --
OLIMEX.dll --
HIL.dll --
FTD2xx.dll  --
Olimex.exe --
Olimex_jtags.inf is date 9/25/2012

Please verify that all the dll and exe are to co-reside in the same directory as the olimex.exe


ooops, problem solved by disconnecting the programmer and reconnecting it.