Welcome, Guest

Author Topic: Modules hardware problems?  (Read 1541 times)

michele_sponchiado

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
Modules hardware problems?
« on: May 12, 2016, 11:08:23 AM »
I am currently using RT5350F with the EVB; after some successful days of working and debugging, suddenly this morning the RT5350F won't power up and it shows a short circuit between 3V3 and GND, the RT5350F is heating up.
We have checked the backplane alone and no short circuit were found.
We replaced the RT5350F module, but this new one shows a strange behaviour: after some seconds from the power up, it hangs or it shows error reading from the SQUASHFS then hangs.  :'(
We cannot reprogram the flash through TFTP because it signals CRC error  or it hangs; with the previous module the TFTP was working great...
Any suggestions?
I wonder if other people have experienced similar hardware problems with the RT5350F!

michele_sponchiado

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
Re: Modules hardware problems?
« Reply #1 on: May 12, 2016, 01:12:20 PM »
Some updates:
* the first module short circuit was probably due to a problem in the 5V power source we were using today: there was a spike up to 6.5V during the power ON, and the power chip inside the RT5350F module can tolerate no more than 6V, so we suspect this was the reason for the short circuit in the 3V3, we are still further investigating
* in the second module, the EN25Q64 serial flash chip was the problem. The flash chip module during the boot was incorrectly identified as an mr25h256 chip instead of an en25q64. We changed it with the one taken from the short circuit module and now the second module works OK, BTW I have reprogrammed the flash and reconfigured the parameters.
* anyone found similar problems from source spikes or SPI flash chip?