Welcome, Guest

Author Topic: IMX233 blink led  (Read 2947 times)

kerob_labs

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
IMX233 blink led
« on: March 16, 2016, 11:05:30 AM »
Hello all!

It's been a while I got my IMX233 Olinuxino Mini, I played a bit with ARM Linux :), but my intention was to port my own embedded RTOS onto it :o, it's very very close to a bare-metal. So the obvious starting point was the famous blink led code that runs as bare metal. Unfortunately I can't make it work...

What I tried:

1) following this:

http://www.jann.cc/2013/08/24/debugging_the_imx233_olinuxino_via_sjtag_with_openocd.html

with no luck so,

2) I tried that:

https://sourceforge.net/p/lyre/code/HEAD/tree/propendous-imx233_board/firmware/1st_bootloader/

I tried both links above in hope to see a blinking led. From the attempt (1), his steps are a bit confusing because it mixes BCB calling ./make_boot_image.sh with MBR using dd (as stated, my intention was just run blink led, I skipped OpenOCD setup). Anyway, I suppose I'm using MBR because I do dd in the first 0x53 type partition to write u-boot and things work perfectly.

Trying (2), I do "make all" and create the image as shown below:

elftosb2 -V -z -c 1st_bootloader.db -o ./output/1st_bootloader_sb.bin

my .db file is standard:

sources {
    image = "output/1st_bootloader.elf";
}

section (0) {
    load image;
    jump image;
}

Then do dd to write to my SD card (I confirmed it is /dev/sdb1, but may vary)

sudo dd if=./output/1st_bootloader_sb.bin of=/dev/sdb1 bs=512 seek=4

When I power up my iMX233 Mini I get this error from the bootloader shown via uart:

0x80501001

to be DCP status error (I suppose the binary was not correctly decrypted?)
In this case, what am I doing wrong here?  :-\

Cheers,

Marcio.




JohnS

  • Hero Member
  • *****
  • Posts: 1723
  • Karma: +33/-48
Re: IMX233 blink led
« Reply #1 on: March 16, 2016, 03:44:08 PM »
I guess you found Chap. 35 of iMX23 ref man.

Maybe the details of bootlets at https://github.com/koliqi/imx23-olinuxino will help

Also, this http://wiki.openwrt.org/toh/olimex/imx233-olinuxino mentions putting u-boot on SD and I suppose you are replacing u-boot in effect.

If you get your RTOS (or other) code working I guess it may be of interest to others.  Olimex may even put it on their pages.

John
« Last Edit: March 16, 2016, 03:49:10 PM by JohnS »

kerob_labs

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Re: IMX233 blink led
« Reply #2 on: March 17, 2016, 01:27:00 AM »
Yeah, I'm familiar with Chap 35...

Indeed my OS has got a boot loader similar to u-boot that loads a binary from a FAT partition in memory and execute. u-boot is very tied to Linux.

I tried a couple of combination but no luck to make it work. Have you tried the blink led project by any chance?

Marcio.

JohnS

  • Hero Member
  • *****
  • Posts: 1723
  • Karma: +33/-48
Re: IMX233 blink led
« Reply #3 on: March 17, 2016, 11:05:23 AM »
I am happy with Linux.

How about starting with a Linux image with uboot.  dd it to an SD card and check it boots & works.

Now look at the image to find uboot.  You should be able to recognise it.

I suppose it won't start where you wrote your file or will have something about it that is relevant to why your simple program does not work.

Or, hope to find a makefile for Linux/uboot that writes to the SD card and figure why that works but your program doesn't.

John

jubjubmane

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
Re: IMX233 blink led
« Reply #4 on: March 26, 2016, 06:05:06 AM »