Welcome, Guest

Author Topic: problem with Pinguino ide & otg board  (Read 2273 times)

zabravanko

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
problem with Pinguino ide & otg board
« on: March 25, 2016, 01:16:47 PM »
Hello,
I have Pinguino otg board. A few months ago I had project with Pinguino Ide/version from 12.2013y. Everything worked fine thru usb programmer. After that I have had some projects with the same board, but with MPLAB X ide thru PICkit3 programmer. Everything was ok again.
These days I am trying to debug some code with Pinguino Ide thru usb programmer, but noting happens. I cant access to bootloader mode, which is strange. I have tried with pushing the two buttons, when the board is powered, as I did a few mounts ago. Actually with Pickit3, everything works.
Do you have some ideas what to do? Drivers or something else? I am still having the old version of Pinguino Ide/12.2013y.
Best regards   
« Last Edit: March 25, 2016, 01:26:10 PM by zabravanko »

LubOlimex

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1752
  • Karma: +45/-2
Re: problem with Pinguino ide & otg board
« Reply #1 on: March 25, 2016, 01:44:46 PM »
Hey,

You probably overwrote the bootloader program. Every board that gets programmed via the USB requires a bootloader program. Use the PICKit3 and MPLAB IPE to restore the bootloader.

You can get the binary of the bootloader from Pinguino IDE or here: https://github.com/PinguinoIDE/pinguino-bootloaders/tree/master/p32/usb - you need the file HIDBoot_MX440.hex (click on it and then click the button "RAW" to download it to your computer).

Best regards,
Lub/OLIMEX
Technical support and documentation manager at Olimex

zabravanko

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
Re: problem with Pinguino ide & otg board
« Reply #2 on: March 25, 2016, 02:22:24 PM »
Thank you for your suggestion. Now everything is ok with board :) .
Have a nice day ;)