June 13, 2024, 01:11:04 PM

Problem with Duinomite eMega?

Started by pcor, December 06, 2012, 12:55:50 AM

Previous topic - Next topic


I got my Duino-eMega a few days ago, but when I plugged in the USB only the red LED lights up. However I was able to put it into upload mode (yellow/green LEDs flashing in sequence). 
After trying a few things I figured maybe it needed to be re-flashed so I installed the usb/serial driver, uploader and got various images ... now I can "connect" to the board when it is in upload mode, but when I try to load any of the hex images it tells me the address space is wrong for my device? I tried a bunch of different hex files, including maximite, Duino-Mega and none of them work; I'm suspecting some address line is bad?
Any suggestions how to fix this, or I just got a duff board? Thanks in advance.


Hello pcor,

Please can you provide me with an image of the error. Please also tell me what VID and PID you see for the board when plugged in bootloader mode (this can be seen in Windows Device Manager - right-click over the board entry -> Properties -> Details - from the drop-down menu select Hardware IDs).

The latest bootloader can be downloaded from the GitHub. The speicific hex you need is Olimex DuinoMite eMega MMBasic Project .hex (you might need to rename it without the space before the extension .hex) located in https://github.com/OLIMEX/DuinoMite/tree/master/SOFTWARE/FIRMWARE .

Note that eMega has special firmware that differs from the firmware of other Duinomite boards we produce.

Best regards,
Technical support and documentation manager at Olimex



I couldn't figure out how to embed images so here they are in my dropbox ..

You can see the device is connected and then the error when I load the HEX file into the USB bootloader; I am using V2.90a ...

I can't see the device in device manager - what category of device is it under? (I reinstalled it and everything seems to go fine; Windows sees a Duino device, etc; I'm using Win XP - could that be an issue?)


I figured out where the "device" went to; when the board is in upload mode it disappears from Device Manager; when you exist the upload mode it reappears as a serial device ...
Also, I tried to download the latest HIDBootloader from GitHub but it is only 28k in size; should be c.150k? Seems that something is wrong there ... 


OK, I solved the main problem; I assumed that when I right-clicked a file on Github and used "save as .." that I would get a correct copy of the file ... apparently not so!
All files downloaded in this way are 28k in length but not the original file ...
What I did to solve this was to list the 'raw' file in my browser (Chrome), save this as text file and then change the extension from 'txt' to 'hex' ... file size increased to 1.4M which is the correct size ...
This gave the correct hex file which I was able to load successfully into eMega and am now doodling with BASIC ...