PIC-P28-20MHz programming issue

Started by sourinia, November 10, 2015, 07:24:50 PM

Previous topic - Next topic

Could you help me with my PIC16F1713 ?




I'm working on a project using a PIC16F1713 (PDIP 28 pins package) with the PIC-P28-20MHz board. Unfortunately, I tried to programm it with a simple blinking prog (MPLABX v3.10) and I just got :

Target Device ID (0x0) does not match expected Device ID (0x3049).

The following memory area(s) will be programmed:
program memory: start address = 0x0, end address = 0x7ff
configuration memory

Device Erased...

Failed to program device

I first thought that it was an ICD3 issue but I tried with another one which was working before but still not working (I read and applicate the ERRATUM note of microchip about the ICD3 issue for this kind of microcontroller.

I read a lot of posts about that and the only error and solution was a switching error between PGC and PGD lines (which is not my case, I checked it a thousand times!).

Does anybody know about this issue ?


Only times I've seen ID 0 there was something wrong with the circuit.  That leaves quite a lot!!



Thanks for answering.

That's what I read too. But I just put the PIC on the olimex board, supplied it and nothing else just to try programming it (without providing power supply from the ICD3, "Target Voltage detected" ok) with a dummy programm so it must work.

I tried :
- with LVP ON and OFF (because I read that for the first programming, the chip might be in that mode),
- powered by the ICD3 and powered with an external power supply,
- on another board ("homemade" board with the Microchip hardware advices for programming)
- with another chip
- with another version of MPLABX

I don't have any more idea...


Try some PIC (PIC16) forums.  I moved to 32-bit chips as fast as I could so have no more ideas.