November 13, 2019, 05:30:49 pm


SMF - Just Installed!

Is my board dead?

Started by zikzak, October 12, 2015, 09:49:50 pm

Previous topic - Next topic


After several months (a year?) without any issue it eventually happened that Transmission refused to seed the content of my HDD. Error about read-only filesystem.
At first I thought it was the HDD.
Ultimately I discovered it was the root on the microsd without any mean to rewrite the fstab I formatted the card and reinstalled the image... several times and it never booted.
Only a red led is on and the etherned led blinked 2 or 3 times.

Any idea to make sure it is not time to replace it?


Happened to me a few times when I powered Olinuxino off without safely turning off the system.
You can create a new bootable SD card and try if it works.


First thing I tried and it did not help.
I tried the official image, Archlinux then with a new SDcard. I never managed to boot it again.


To get a definitive answer, you may want to attach UART cable and take a look on boot console output. This usually displays quite a verbose boot progress and error messages. And unless hardware is completely died you'll see more info on boot progress. And hints on what went wrong during boot.

Actually, some innocent-looking things can make system unbootable. Sometimes these can be quite dumb. Either way, uart cable is a must have thing to troubleshoot boot fail misteries in small devices. Olimex even sells these at affordable prices, like

And another thing to try is pressing "u-boot" button and booting off CPU ROM (by sending all boot code via usb). This way you can run u-boot even if your card is not operational at all, as long as CPU alive and can read from USB. Though, once again, it is handy to get serial cable to see what's going on. And if system is alive and you do not understand some message, post it here.

And another thing: check your power supply. Since you've ran it with HDD, you see, electrolytic caps can go nuts under heavy loads over time, and most often it happens in power supply itself, causing voltage spikes exeeding hardware tolerance and eventually getting unstable operation. Or supply can just provide inadequately low voltage, etc. This could be a case, because RO file system possibly means your system wasn't stable during operation and possibly got data corruption. Try starting without HDD and preferrably, using known good power supply, etc or from USB port (without HDD, usb ports usually can't deliver enough power for it). This is especially true if you've used some cheap low-quality power supply. These usually die in a year or two, causing weird glitches due to reduced or poorly filtered voltage.



Thanks! Both solution will require the UART cable.
I'm tempted to by an A20 and order the cable at the same time as it might prove useful one day. Or I wait for the shiny new (promising) boards.

Note that the PSU I used is the one I bought from Olimex with the A10 itself.


FEL-boot is USB not uart.



OK, I was not sure from the wiki page I read as they wrote things about UART.
FEL doesn't seem to exist for MS-Windows, for now only my ARM boards are running GNU/Linux and my laptop is still under Windows.


You can dual-boot Windows and Linux.  You can even run Linux off a USB stick leaving your Windows unchanged.