Welcome, Guest

Author Topic: setting cpu frequency  (Read 2842 times)

BrianBrianBrian

  • Newbie
  • *
  • Posts: 18
  • Karma: +3/-0
setting cpu frequency
« on: August 22, 2015, 05:42:34 AM »
I would like to underclock the AM3352 to save power.  However, it seems that no matter how I try to manipulate the cpu frequency via the cpufreq utils, the frequency remains at 1000MHz.  For example:

# echo 600000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_setspeed
# cpufreq-info
Report errors and bugs to cpufreq@vger.kernel.org, please.
analyzing CPU 0:
  driver: generic_cpu0
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 300 us.
  hardware limits: 300 MHz - 1000 MHz
  available frequency steps: 300 MHz, 600 MHz, 720 MHz, 800 MHz, 1000 MHz
  available cpufreq governors: conservative, powersave, userspace
  current policy: frequency should be within 300 MHz and 600 MHz.
                  The governor "userspace" may decide which speed to use
                  within this range.
  current CPU frequency is 1000 MHz (asserted by call to hardware).
  cpufreq stats: 300 MHz:0.00%, 600 MHz:0.00%, 720 MHz:0.00%, 800 MHz:0.00%, 1000 MHz:100.00%

A run of whetstone also confirms that the cpu frequency is still at 1000MHz.  Does anyone know why the cpu frequency seems to be stuck at the maximum?
« Last Edit: August 22, 2015, 05:44:38 AM by BrianBrianBrian »

BrianBrianBrian

  • Newbie
  • *
  • Posts: 18
  • Karma: +3/-0
Re: setting cpu frequency
« Reply #1 on: August 23, 2015, 04:04:53 AM »
I also noticed that the kernel log has the following message:

cpufreq_cpu0: failed to scale voltage down: -22

whenever I tried to change the cpu frequency.

BrianBrianBrian

  • Newbie
  • *
  • Posts: 18
  • Karma: +3/-0
Re: setting cpu frequency
« Reply #2 on: August 23, 2015, 05:53:06 AM »
And here is the power management section from the kernel config:
(cat /proc/config.gz | gunzip > running.config)

#
# CPU Power Management
#

#
# CPU Frequency scaling
#
CONFIG_CPU_FREQ=y
CONFIG_CPU_FREQ_TABLE=y
CONFIG_CPU_FREQ_GOV_COMMON=y
CONFIG_CPU_FREQ_STAT=y
CONFIG_CPU_FREQ_STAT_DETAILS=y
# CONFIG_CPU_FREQ_DEFAULT_GOV_PERFORMANCE is not set
# CONFIG_CPU_FREQ_DEFAULT_GOV_POWERSAVE is not set
CONFIG_CPU_FREQ_DEFAULT_GOV_USERSPACE=y
# CONFIG_CPU_FREQ_DEFAULT_GOV_ONDEMAND is not set
# CONFIG_CPU_FREQ_DEFAULT_GOV_CONSERVATIVE is not set
# CONFIG_CPU_FREQ_GOV_PERFORMANCE is not set
CONFIG_CPU_FREQ_GOV_POWERSAVE=y
CONFIG_CPU_FREQ_GOV_USERSPACE=y
# CONFIG_CPU_FREQ_GOV_ONDEMAND is not set
CONFIG_CPU_FREQ_GOV_CONSERVATIVE=y
CONFIG_GENERIC_CPUFREQ_CPU0=y

#
# ARM CPU frequency scaling drivers
#
# CONFIG_ARM_KIRKWOOD_CPUFREQ is not set
# CONFIG_ARM_OMAP2PLUS_CPUFREQ is not set

#
# CPU Idle
#
CONFIG_CPU_IDLE=y
# CONFIG_CPU_IDLE_MULTIPLE_DRIVERS is not set
CONFIG_CPU_IDLE_GOV_LADDER=y
CONFIG_CPU_IDLE_GOV_MENU=y


The only thing that seems suspicious to me is that there is no frequency scaling driver set.  Is this the problem?