Extremely slow Ethernet on A20-OLinuXino-LIME2

Started by StupidBeard, July 16, 2015, 10:01:57 pm

Previous topic - Next topic

soenke

well, which of the problems are you referring to? Network packet losses or system freeze?

dario

Those who faced the issue said it is a problem with a specific variable in U-Boot, namely CONFIG_GMAC_TX_DELAY. I thought the SD card thing was not related. I have a class 4 microSD that is quite slow indeed. Why would a faster SD card fix the problem? Perhaps it is a caching related issue? I will try with a faster SD card and let you know.

dario

I am referring to the packet loss in 1000 Mb/s mode.

soenke

Then the timing of gmac might be the solution, please report back if that works.

You can also try if a faster sd card helps (class 4 is quite slow for running an os) but my guess is that it is not related to the packet losses. Also try another cable and adding another gbit-switch between the A20 and the router, it could also be related to the physical signals.

dario

Thank you for your reply. Forcing 100 MB/s via software eliminates the problem, therefore I think the issue is unrelated. I will try with a faster microSD though (I know, it's quite slow). I have been looking on the Internet if anybody had come up with a solution to no avail. It seems nobody has yet to find a good combination of values for proper 1000 Mb/s connection. Do you own an A20-OLinuXIno-LIME2? Are you experiencing the same issue?

soenke

Yes, i have some A20's but none of them is on a gigabit switch ;)
But i will make some tests to see if i can reproduce it.

dario


Gronis93

Hi everyone!

I have the same issue with my lime2 board, only that it is only on the downlink. The uplink has about 60MB/s (480Mbit/s) but the downlink is stuck at about 50kB/s which is terrible.

I bought this board only to run as a server with a gigabit link. I even upgraded my router, so that I could use the gigabit speeds. I have had this problem since I bought the board earlier this year. I have tried two different routers, 3 different cables, with and without a switch in between the router and the board, but the problem remains.

From what I have learned reading this thread, it seams like a software issue.  I'm not sure if I can help in this discussion, but like you guys, I really want to solve this problem :)

I'm using kernel 4.1.2

JohnS

It does seem to be software and it appears to be open source so go for it if you want it faster :)

John

dario

I have yet to get hold of a faster microSD to try out, but I'm pretty confident it won't fix the issue. Gronis93, what's the actual speed of the microSD with the operating system installed?

Gronis93

I have tested IO speeds with dd and get around 8MB/s with when writing zeroes to the home folder, and 19MB/s when reading a file into /dev/null

So there should not be a problem with the sd-card. I have ordered a new sd-card and I am going to try different distributions and kernels on that sd-card (don't want to ruin my server install for the moment). Dario, how fast is your sd-card?

Gronis93

Also, I want to add that if I start many simultaneous downloads, all of them are capped at 100~30kB/s. This is a further indication that the speed is capped by the software. Probably there is a large amount of package loss witch slows it down.

StupidBeard

Hey,

Gronis sent me a PM, which I replied to, but thought I would also mention it here for anyone else who comes along later.

I gave up swearing at it and just plugged the board into a 100mbit switch. An alternative solution is to use ethtool in a pre-up script for force eth0 to always use 100mbit.

I'd still like a proper solution, but I have so many other things to do that it's unlikely I'll get back to this for quite a long while.

Stupid Beard.

dario

Gronis93, I have tested the speed the same way as you did and I use my OLinuXino as a network server as you do. Actually, it is quite slow and my microSD is the same as yours. I get the same speed. It is a class 4 microSD card and it's too slow for general use. In regard to what StupidBeard wrote in the last post, it seems the only workaround so far is to connect the board to a 100Mb/s switch OR cap the speed via software with something like mii-tool eth0 -F 100baseTx-FD This solution, however, is not feasible for my needs because I get very slow transfer speed on my LAN. I bought this board specifically for the gigabit capability.

dario

December 04, 2015, 12:49:31 am #29 Last Edit: December 04, 2015, 01:11:52 am by dario
I have tried the official Debian images from Olimex, the Debian image from the Debian website and Arch Linux to no avail, it's slow as hell.

EDIT: I filed a bug report to Olimex on GitHub: https://github.com/OLIMEX/OLINUXINO/issues/31