Re: Amtel Studio 6.2 and Olimex AVRISPMK2 chip programming

Started by StevePerry, September 18, 2015, 11:43:51 AM

Previous topic - Next topic



Thought this was as good a place as any to post this. Basically this Olimex spi programmer is going to get the sledge hammer treatment. I've wasted an entire day trying to fix this issue.
- avr studio 6.2.
- windows 7 64 bit
- using attiny13a on breadboard with 10 pin icsp10 port. used data sheets. yes the pins are correct.
- tried updating firmware per olimex user manual and changing back, tried updating all sorts of usb drivers from olimex and atmel. lights flashed here and there but thats about all this pos is good for.
- tried external power for the chip and all sorts of jumper conifgurations.
- zadig_2.1.2 did get me a bit further replacing the driver with a generic (per another post somewhere on the internet) but the got stuck again with visual stuido exclaiming the target was not found, throwning 20000 error which had a very little support and someone suggesting i use avr dude. now im back to trying to get the stupid original drivers it originally came with working again, and, you know what?

cant be bothered. ill by a genuine avr spi programmer.

see you later olimex. suggest anyone else wanting to buy this product do so for sledge hammer testing purposes.


Hey StevePerry,

Don't stop believing!

Sometimes the connection problems are much simpler - it might be a faulty USB hub, or USB port or cable that provides insufficient current or breaks a dataline. I'd also suggest testing with another target, sometimes connection problems can be related to a locked or fried target.

One really simple software suggestion is to try with a previous version of Atmel Studio (for example, 6.1) or with AVR Studio 4. Sometimes newest versions of software introduce new bugs. Some of these bugs affect Atmel products as well, if you browse the "avrfreaks" forums you would discover that Atmel programmers also have problems and bugs.

I've been running Atmel Studio 6.2 with AVR-ISP-MK2 under Windows 7 x64 without any problems. However, I've had few reports of people that had the same problem as you. Few of them reported that this behavior is caused by driver mismatch (the system has USB drivers left over from Atmel Studio 6.1 which are different from the drivers expected from Atmel Studio 6.2). They were able to get it working by using the drivers from the latest studio. The following steps should make it work:

1. First try to uninstall any driver related to AVR-ISP-MK2 – keep uninstalling until the unit is no longer recognized by Windows (the entry in "Windows Device Manager" would show the lack of driver).

2. Then download the latest USB driver from the Atmel Studio 6.2 – this is done by navigating to Tools –> Extension manager. Log in to your Atmel account (or make one for free) and then type "USB" in the search bar of the interface. Select "Atmel USB installer" and click "Download". Save the file, then disconnect AVR-ISP-MK2 from the computer and execute the file that you downloaded (the versions should be the latest one by the time of writing this post - 7.0.888, no matter the build of the Atmel Studio). Follow the onscreen instructions.

3. If the problem persists then try another way to change the drivers (do this only after you have tried the above method and it wasn't successful):
Remove the all drivers again as mentioned in step one (1.) and then download Zadig: Zadig is a USB driver manager for Windows. The program comes with ready-to-use libusb-win32 drivers.

- Open Zadig, Options, List All Devices. The AVRISP mkII device should appear in the list.
- Use the interface arrows to select the libusb-win32 driver. Click the big button "Replace" to change the currently listed driver with libusb-win32 (v1.x.x.x).
- Wait till the replacement succeeds and the reboot your computer.

4. Make sure that the Windows Driver Signature enforcement is disabled. By default new versions of Windows block devices that are not present in their driver database (and to be present there you would need to pay annual fee). Information about the procedure varies for different Windows version, and there are a lot of guides available online. However, I've used this guide before:

5. If all of the above fails multiple times try to install Atmel Studio 6.1 instead of Atmel Studio 6.2. Previous versions of the studio might be found in the archives here:

Best regards and good luck in your journeys,
Technical support and documentation manager at Olimex


Sorry - I thought everything was working. its not. yes i did have the pins wired incorrectly but this has still not resolved the issue. i was able to read the chip serial number and edit fuses (although i didnt - yes im aware you can brick it if you change certain fuses) but have run into more issues with the mk2 being busy after an attempt to run. closing atmel studio 6.2 and reopening sometimes fixes this. i have tried installing a previous version (6) and this gets me back to original driver issues (target not found). i have just tried disabling windows driver signing and installing libusb drivers and this too doesnt change anything.

I have given up. will try once more to to flash firmware and abandon atmel studio and go with avr dude. this really pisses me off. it seems the combination of attiny, atmel studio and olimex is just not a good one. zadig doesnt even help me anymore with studio 6. so over this.

thanks for your help anyway.