Welcome, Guest

Author Topic: sometimes linux boots but is not ssh-able  (Read 1928 times)

albvalente

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
sometimes linux boots but is not ssh-able
« on: June 03, 2015, 12:02:37 PM »
Hello,

sometimes my A10-4Gb boots (linux from sd) but cannot ssh into it.
If I connect with serial debug interface I see it is running, ifconfig shows correct parameter for eth0 (it has a valid IP) but I cannot login into it via ssh nor access webserver and Codiad.
Usually a reboot is enough to make it work. Sometimes I need to reboot twice.
Any clue?
Maybe a not-clean shutdown can damage sd filesystem?

thank you

MBR

  • Sr. Member
  • ****
  • Posts: 256
  • Karma: +19/-0
Re: sometimes linux boots but is not ssh-able
« Reply #1 on: June 03, 2015, 11:22:04 PM »
Unclean shutdown can damage the filesystem, but the symptoms are different (e.g. stopping aftert the filesystem check with manual repair request, or not able to boot at all, even after reboots), this looks more like some problem with configuration. Is the network address static or dynamic (via DHCP)? Does it help when you change it? And when you log via serial interface, are the ssh daemon, the webserver and other network-related processes running and to what addresses are they bound? (you can get it with netstat -a -t).

albvalente

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
Re: sometimes linux boots but is not ssh-able
« Reply #2 on: June 05, 2015, 11:32:53 AM »
yesterday it worked all day long flawlessy  :o
whenever it will do it again I'll try your suggestions

thank you