Preparing LINUX on Mac OS X 10.6

Started by nejemia, November 27, 2012, 11:53:50 pm

Previous topic - Next topic

nejemia

Dear all:
Just received a couple of iMX3-Olinuxino boards MAXI.
Preparing the Linux image using the Mac is driving me nuts.
Mac is not Linux, it is similar but does not support most of the features required to format microSD cards for Linux use.
I wonder if someone can provide me with an already working image of any version of Linux (Debian is OK) so I can just use dd command from the Mac Terminal and start testings.
Preparing the Linux for the Raspberry was nice and smooth with my Mac, so I believe it can be done for the OLIMEX also.
I appreciate this very much in advance.
Any suggestion or recommendation is very welcome.
By the way, I need the Tools to compile my own code (g++ or just gcc will do).
Thank you so much.
Nelson --

jlumme

As for prebuilt debian image, you can find one here; https://github.com/OLIMEX/OLINUXINO/blob/master/SOFTWARE/iMX233/DEBIAN/DEBIAN-README.TXT
You still need to prepare the memory card with linux file systems, though. Maybe booting up a livecd would be doable ? It's a pain, but at least a temporary solution.

As for compilers, you need ARM cross compiler for your OS, not sure how that works in Mac world.
If you get Linux running on your board and ssh to it, one way could be installing compiler from package manager, and mount a drive through network and compile natively there (you don't want to be compiling much code in your sdcard)

Cure

Has anyone gotten this prebuild Debian image to work?:
https://github.com/OLIMEX/OLINUXINO/blob/master/SOFTWARE/iMX233/DEBIAN/DEBIAN-README.TXT

I followed the steps but I'm wondering about the 'sudo mkfs.ext2 /dev/sdb2' is that correct?

When it finally boots up I get this far before it stalls, any ideas:



Waiting for /dev to be fully populated...done.
Activating swap...done.
EXT4-fs (mmcblk0p2): re-mounted. Opts: (null)
Checking root file system...fsck from util-linux-ng 2.17.2
/lib/init/rw/rootdev was not cleanly unmounted, check forced.
/lib/init/rw/rootdev: 13922/237568 files (0.1% non-contiguous), 116459/948992 blocks
fsck died with exit status 1
failed (code 1).
EXT4-fs (mmcblk0p2): re-mounted. Opts: (null)
Cleaning up ifupdown....
Setting up networking....
Loading kernel modules...done.
Activating lvm and md swap...done.
Checking file systems...fsck from util-linux-ng 2.17.2
done.
Mounting local filesystems...done.
Activating swapfile swap...done.
Cleaning up temporary files....
Configuring network interfaces...cat: /sys/class/net/usb0/address: No such file or directory
run-parts: /etc/network/if-pre-up.d/00-persistent-mac exited with return code 1
cat: /sys/class/net/usb0/address: No such file or directory
run-parts: /etc/network/if-pre-up.d/00-persistent-mac exited with return code 1
SIOCSIFHWADDR: No such device
Failed to bring up usb0.
done.
Cleaning up temporary files....
Setting kernel variables ...done.
INIT: Entering runlevel: 2
Using makefile-style concurrent boot in runlevel 2.
Starting NTP server: ntpd.
Starting OpenBSD Secure Shell server: sshd.
INIT: Id "1" respawning too fast: disabled for 5 minutes
INIT: no more processes left in this runlevel
INIT: Id "1" respawning too fast: disabled for 5 minutes

jeroends

I doesn't stalls, the reason why you got this is because I made a mistake in the inittab and I have to recorrect it. The load is up and runnign but only accessible through ssh.
What needs to be changed in the inittab (file: /etc/inittab, if you open in on another pc you can edit it) is the last line.
1:2345:respawn:/sbin/getty -L ttyAM0 115200 vt100

has to be:
1:2345:respawn:/sbin/getty -L ttyAMA0 115200 vt100

Sorry for that, will fix it soon as I can (If I don't forget about it again  ;) )

Cure

Thanks that fixed it!  I'm finally seeing the login prompt, however it's not allowing me to use "root" as the login name.  Whenever I type "root [enter]", it doesn't ask for a password, it just skips a line and says Login incorrect, any ideas?

------------------
debian login: root

Login incorrect
debian login:
------------------

Cure

Nevermind, found the answer here:
https://www.olimex.com/forum/index.php?topic=263.msg1828#msg1828

Edit /etc/securetty
add line: /dev/ttyAMA0

Thanks for the quick response from earlier, can't wait to start using Debian!