Welcome, Guest

Author Topic: Boot error [SOLVED]  (Read 2109 times)

elamre

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
Boot error [SOLVED]
« on: April 02, 2015, 01:24:23 PM »
Hello.
I played around a lot with my iMX233 board and installed arch linux several times, succesfully.
However a few days ago i had to reinstall everything again, due to power loss while updating (sad story).

The problem now is that i keep getting error code:
0x80502008
          0x8020a01d
every twenty seconds.

I have looked up what these mean, and searched trough the forum. But my power supply seems fine, and is more than capable supplying plenty of current (12v-5A). I ran some quick measurements and the powersupply on board seems fine too. This leads me to believe that this can not be the issue.
Now on the sd card, I've tried two different sd cards, and followed the instructions given on the arch linux arm site strictly. Which regretfully did not work, also didnt work after 5 times.

I know some of linux, but not enough to solve this myself. I'm starting to go insane with this error. Is there any power supply that i should be measuring?
Ive also tried formatting the sd card in gparted (what file system should the uboot partition be?). However when formatting both the arch linux distrubution partition and the uboot partition to ext4, the uboot partition gives me a warning.

dumpe2fs 1.42.8 (20-jun-2013)
dumpe2fs: invalid argument while reading journal inode


Thanks so much in advance! I'm starting to go insane

Edit: its the olminex maxi
« Last Edit: April 02, 2015, 02:24:16 PM by elamre »

mbergmann

  • Jr. Member
  • **
  • Posts: 61
  • Karma: +3/-0
    • My blog
Re: Boot error
« Reply #1 on: April 02, 2015, 01:45:01 PM »
0x80502008 is ERROR_ROM_USB_CONNECT_TIMEOUT
0x8020a01d is ERROR_DDI_SD_MBR_NOT_FOUND

It seems the SoC did not find the MBR of your card and tried recovery mode instead but failed, too.

Did you checked the layout of you card?

Short description about how to make bootable SD card with Linux file system for OLinuXino boards:

https://olimex.wordpress.com/2012/07/05/building-arch-linux-distribution-for-imx233-olinuxino/

Regards

Mike

elamre

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
Re: Boot error
« Reply #2 on: April 02, 2015, 02:23:46 PM »
 :-[
I forgot to set the partition type. I feel so silly now. Thanks :)