Welcome, Guest

Author Topic: Using KEIL examples on LPOC-P1343  (Read 2949 times)

kabumei

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Using KEIL examples on LPOC-P1343
« on: March 19, 2015, 10:12:41 PM »
I just got the Olimex LPC-P1343, and figured it shouldn't be difficult to get the Keil MCB1343 examples to run on it -- just change the IO configuration, right? The keil blinky routine compiles, and I can see it run in the debugger, but nothing I do can get the IO bits to change. I've tried all the usual suspects -- initialization, direction, etc.  Anyone have a clue?

JohnS

  • Hero Member
  • *****
  • Posts: 1674
  • Karma: +33/-45
Re: Using KEIL examples on LPOC-P1343
« Reply #1 on: March 20, 2015, 12:09:07 AM »
Try a sample known to work, with a different toolchain?

(e.g. gcc cross-compiler - it's free)

John

kabumei

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Re: Using KEIL examples on LPOC-P1343
« Reply #2 on: March 20, 2015, 03:48:55 PM »
I appreciate the simplicity of that approach, but it's not just this example I'm trying to make work, and I'm not blaming the Olimex board. I wanted to prototype my product on the Olimex, and for that I'll need all my Keil tools. I just can't think of anything my super simple code is doing that wouldn't work on the board. So I'm going to try starting over from scratch, one line at a time...

JohnS

  • Hero Member
  • *****
  • Posts: 1674
  • Karma: +33/-45
Re: Using KEIL examples on LPOC-P1343
« Reply #3 on: March 20, 2015, 05:40:13 PM »
Something like not enabling the I/O.

John