AM3352 SOM debian sources?

Started by ocklin, March 07, 2015, 05:09:21 pm

Previous topic - Next topic

ocklin

Apologies if I have missed them somewhere but are the Debian sources for the AM335s available somewhere? If not, can you please publish them on github?

The torrent images look a lot like the BB's but there obviously differences.

Thanks,
Bernd


vinifr

April 18, 2015, 03:31:47 am #2 Last Edit: April 18, 2015, 03:37:25 am by vinifr
hi,

How to install the u-boot on the uSD card?

I used these commands:
dd if=spl/u-boot-spl.bin of=/dev/sdc bs=1024 seek=8
dd if=u-boot.bin of=/dev/sdc bs=1024 seek=32

but does not work.

Chester Gillon

Quote from: vinifr on April 18, 2015, 03:31:47 amI used these commands:
dd if=spl/u-boot-spl.bin of=/dev/sdc bs=1024 seek=8
dd if=u-boot.bin of=/dev/sdc bs=1024 seek=32
The files to be transfered to the SD card for uboot on the AM3352 SOM are MLO and u-boot.img. See the "5. Write the Uboot on sd card" instructions on https://www.olimex.com/wiki/Building_Debian_AM3352_SOM for details.


[Following the instructions on the referenced Wiki page I was able to compile, install and run uboot on am AM3352 SOM]

vinifr

This is very interesting. I have not used dd command, instead I used a simple cp command and works. But I copied the files you mentioned, MLO and u-boot.img, to first fat16 partition.

I followed these instructions: http://www.armhf.com/boards/beaglebone-black/bbb-sd-install/

vinifr

My system is stuck here:


[FAILED] Failed to start OpenBSD Secure Shell server.
See 'systemctl status ssh.service' for details.
[ TIME ] Timed out waiting for device dev-ttyO0.device.
[DEPEND] Dependency failed for Serial Getty on ttyO0.
[  OK  ] Reached target Login Prompts.
[  OK  ] Reached target Multi-User System.
[  OK  ] Reached target Graphical Interface.
         Starting Update UTMP about System Runlevel Changes...
[  OK  ] Started Update UTMP about System Runlevel Changes.

ignat99

May be for some body will interesting haw change the image:

sudo apt-get install p7zip-full
7za e am3352_debian_3_12_vga_1024x768_preliminary_release_3.7z


sudo fdisk -lu ./AM3352_debian_3_12_VGA_1024x768_preliminary_release_3.img

Disk ./AM3352_debian_3_12_VGA_1024x768_preliminary_release_3.img: 2001
MB, 2001731584 bytes
27 heads, 8 sectors/track, 18100 cylinders, total 3909632 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00046134

Device                                         
./AM3352_debian_3_12_VGA_1024x768_preliminary_release_3.img
Boot             
1
Start
2048
End
3909631
Blocks
1953792
Id
83
System
Linux

Calculate offset - size of sector * Start:
512*2048=1048576

Mount:

sudo sudo losetup -o 1048576 /dev/loop0
./AM3352_debian_3_12_VGA_1024x768_preliminary_release_3.img
mkdir loop
sudo mount /dev/loop0 ./loop/

Check:

ls loop/
bin  boot  dev  etc  home  lib  lost+found  media  mnt  opt  proc
root  run  sbin  srv  sys  tmp  uEnv.txt  usr  var

Unmount:

sudo umount ./loop
sudo losetup -d /dev/loop0

vinifr

Quote from: Chester Gillon on April 18, 2015, 04:40:41 pm
[Following the instructions on the referenced Wiki page I was able to compile, install and run uboot on am AM3352 SOM]

Hi Chester,

Are you able to login ttyO0 terminal?

ferhat

Hi,

Are you able to login ttyO0? I have stucked at the same point

Quote from: vinifr on April 20, 2015, 03:31:17 am
My system is stuck here:


[FAILED] Failed to start OpenBSD Secure Shell server.
See 'systemctl status ssh.service' for details.
[ TIME ] Timed out waiting for device dev-ttyO0.device.
[DEPEND] Dependency failed for Serial Getty on ttyO0.
[  OK  ] Reached target Login Prompts.
[  OK  ] Reached target Multi-User System.
[  OK  ] Reached target Graphical Interface.
         Starting Update UTMP about System Runlevel Changes...
[  OK  ] Started Update UTMP about System Runlevel Changes.


vinifr

Hi,

Well, now i'm using Beaglebone kernel: https://www.olimex.com/forum/index.php?topic=4942.0. I don't have this problem with this kernel.

ferhat

Hi ,
Thank you for the reply.

I am also using this kernel
git://github.com/beagleboard/kernel.git
v3.8.13

and debian8.3 minimal filesys

at first boot I can connect to login screen via serial ttyO0 but when I restart again I could not any more.

What may be the problem?


vinifr

March 30, 2016, 06:33:29 pm #11 Last Edit: March 30, 2016, 06:41:38 pm by vinifr
hmm, I see.

In beaglebone kernel you need to use ttyS0 instead ttyO0.  ;)

But that is strange. The kernel version should be 4.1, link: https://github.com/beagleboard/linux

ferhat

the problem is solved with below kernel patch

https://github.com/gumstix/meta-gumstix/commit/1f2c3a8a1cafd5451ef28584ce7c0d654147a2a8

which states :
Serial TTY (ttyO2 and ttyGS) fail to spawn on 2nd boot without FHANDLE
enabled.