[solved] need help with PIC32-PINGUINO-MX220

Started by dsp, June 01, 2015, 09:30:33 PM

Previous topic - Next topic


I have spend a few days already looking for answeres how to get this running:

I have a PIC32-PINGUINO-MX220 and I would like to use it.
I installed latest pinguino-ide versions from svn, from git, on Archlinux, Debian, OSX and Windows.
I am loosing hope that pinguino IDE will work for me and found MPIDE which looks very promising. Is it possible to use with the MX220? Do I need a programmer? Or what about UECIDE?

Current state of getting pinguino to work:
* Windows
Most promising so far is Windows: only thing that does not work is the board does not get recognized.
I can see it in Windows Hardware Manager as Input Device, when I enter Bootloadermode (Red and Green lights flashing fast). I never get asked for drivers and I can't change the driver (If I select "update driver" and then choose the right .inf file from hacking labs) Windows tells me that there is no suitable driver present.

* Debian
I used the install script to isntall compilers and ide. When linking ld is complaining it cant find -lgcc. From what I have read is, that static library libgcc is missing. How can I get this and where should it be.

-- both these scenarios I have already found in various forums, unfortunately with no solution --

* Archlinux
when compiling libmpc.so.2 was missing. When I made a symlink in /usr/lib to libmpc.so.3.0.0 next thing libgmp.so.3 was missing. (symlink-> so.10.2.0) New Errors came -> gave up and switched to Debian...

Any help would be greatly appreciated!
I would really like this board to work. Currently I have borrowed an Arduino which I was planning to exchange with this board.

Thank you for reading.


wow, that forum post really helped...

it works now in Windows with the old version (rev999) of pinguino-ide available here:

it seem to be connected with the code of the IDE, not the driver. When I try to do same thing with same setup pinguino version 11.0 beta.3 doesn't find the MX220 while the rev999 uploads everything just fine.

I am very happy to be able to start using it.