Error for Arch linux image

Started by Geetika, February 03, 2015, 03:20:32 pm

Previous topic - Next topic

Geetika

I am trying to copy the arch linux image for A20-OLinuXino micro board in my sd card through the procedure given by olimex site: https://alarma20.wordpress.com/2013/09/13/howto-build-arch-linux-arm-for-a20-olinuxino-micro/

In second step of Building u-boot, after the command:
make A20-OLinuXino_MICRO CROSS_COMPILE=arm-linux-gnueabihf-, I am getting the following error:
Makefile 479: *** "System not configured - see README" .STOP.

Please help ASAP.




Gerrit

they forgot a step

make CROSS_COMPILE=arm-linux-gnueabihf- {TARGET}_config

for more details http://linux-sunxi.org/U-Boot#Compilation

progmetalbg

Better use the bolded version on top of the page. The other part is outdated (written in September 2013).
The new way is also quite easy and the produced image is supported by Arch Linux ARM community (you'll receive kernel & u-boot updates).

Geetika

I tried the above steps you have suggested and it worked out. But again I am stuck in between.

I reached to the 3rd step: Get the board specific FEX file and create script.bin.

After giving the following command:
./fex2bin a20-olinuxino_micro.fex > script.bin, I am getting the foll error:
bash: ./fex2bin: No such file or directory

PLease help ASAP.