July 22, 2024, 05:37:59 AM

Olimex PicKit3 problem

Started by pnpn, February 08, 2015, 10:20:43 AM

Previous topic - Next topic


Dear all,

I am trying to get a new Olimex PicKit3 working, but without success:

If I connect the PK3 via USB cable (no target connected) I get (under Linux)

[ 3508.976636] usb 3-12: new full-speed USB device number 5 using xhci_hcd
[ 3509.106643] usb 3-12: New USB device found, idVendor=04d8, idProduct=900a
[ 3509.106647] usb 3-12: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 3509.106650] usb 3-12: Product: PICkit 3
[ 3509.106652] usb 3-12: Manufacturer: Microchip Technology Inc.
[ 3509.106654] usb 3-12: SerialNumber: OLI353550181
[ 3514.103415] usbhid 3-12:1.0: can't add hid device: -71
[ 3514.103426] usbhid: probe of 3-12:1.0 failed with error -71

Under Windows (I tried XP and W7, also in safe mode), PK3 is also recognized as HID device but there is an exclamation mark in Device Manager.

Is it possible that the PK3 is broken?

Once, I had the PK3 recognized under Linux with MPLAB IPE, but it reported an error after "connecting" (whatever that means)

I start to wonder whether the different Microchip programs I tried managed to put the PK3 into a strange state from which it cannot "recover".

What I don't understand is how the "firmware" is stored. Is it flashed and therefore possible to break the device if this fails? Or is there kind of a fixed "bootloader" that stays under all circumstances and provides the HID interfacing? Is there a way to "reset" the PK3 to some defined state?

Thanks for your help