July 19, 2024, 06:33:45 AM

Router WIFI interference

Started by kenjohn, March 28, 2014, 04:29:06 PM

Previous topic - Next topic


Belkin router

I recently obtained a Picweb board loaded with version 5 software. All seemed to be fine.

I upgraded the software to version 5.42.

This caused the WIFI to become unstable preventing wireless connection to the internet.

Connections via Ethernet to the router could still access the internet.

Using a second router in bridge mode between the Belkin and PICWEB had no effect.

Reverting back to version 5 software (with all leads and connections exactly the same) cleared the problem.

Does anyone have any ideas as to what the problem is or has anyone else experienced this problem?

Also DynDNS does not work on v5.42 but is fine on v5????

Thanks for reading.



Hi John!

Can you share more details about your WiFi problem. I don't understand what do you mean by "WIFI to become unstable preventing wireless connection", since PIC-WEB board doesn't have WiFi at all. Recently we released a project that includes WiFi demonstration but the wireless connection is achieved using MOD-WIFI attached to the UEXT of the PIC-WEB. And I don't understand how is it working with version 5.

As for your other question about the DNS.
I guess it is caused by the TCP/IP configurations.
In older stack it seems there is only one macro that turns on/off DNS - check file "TCPIP Config.h", line 87, macro STACK_USE_DNS.
In the new stack there are two macros about the DNS. Check the file "\Configs\TCPIP OLIMEX_PIC_WEB.h", line 84-85, macros STACK_USE_DNS, STACK_USE_DNS_SERVER.
The first one is defined but the second one is commented by default and when I did the demo I didn't change that. If you need it maybe you should try to uncomment it, recompile and reprorgam.

Stenli, Olimex
May the Source be with You!


Hi Stemli,
Thanks for your reply.
With v5.42 running when a device such as an iPhone, laptop, games console etc tries to connect to the internet via the routers wifi "unstable wifi" is reported on the device and it will not connect even though it has a strong signal.

The main computer that I am using is connected to the router via Ethernet is unaffected.

I used another router in bridge mode between the PICWEB and the main router, but this had no effect.

Downloading v5 to the PICWEB, without changing any physical connections, cured the problem so I'm sure this is a software problem rather than something like an earth loop.

I've tried this several times and re-downloaded v5.42 and always get the same result.

I'll try the DDNS later though I am pushed for time. Only 54 days before MPLAB C18 times out (strange way to promote hardware sales) can you be of any help there please.

Just one last thing. How do I change the HTTP port number in v5? Easily done in v5.42 but scratching my head on v5.

Thanks for your time.



Hey John,

You can install the "LITE" version. It is not limited in time.

The evaluation version is the full version just limited in time. The LITE version does not include code optimizations and will produce bigger binary output, slower compilation and such.

You can download and use the LITE version from here: http://www.microchip.com/Microchip.WWW.SecureSoftwareList/secsoftwaredownload.aspx?device=en010014#(third link).

The LITE version was tested with the demo and it compiles and runs fine.

Best regards,
Technical support and documentation manager at Olimex


That's brilliant Lub.