A10 appears to not boot

Started by eroosenmaallen, August 21, 2014, 07:14:02 pm

Previous topic - Next topic


I now have two A10 boards which appear to be DOA. I have connected Ethernet, HDMI, and the USB-SERIAL-F cable, and have inserted an SD card with A10 Debian preinstalled. When I apply power (5V 2A), the Power light comes on, then the Ethernet Link light, then the Ethernet Activity light begins to blink, but nothing else happens - no output to HDMI or UART0, no activity on LED1, no DHCP lease shows in the router. I have two boards with the same behaviour.

I connect to the USB serial adapter at 115200.

Any ideas? Am I missing a setup step?



Did you enable the eth0 interface in "/etc/network/interfaces" ? Because its down by default.
You might need an other computer with a SD card reader to edit this file.

As for the screen, default is HDMI 720p/60Hz. You will be able to change the conf by running the "change_display.sh" script found in the "/root/" dir on the SD card (once you managed to get remote access to the board).

Maybe it's possible to do all of this accessing the board throught the USB OTG, but I don't know how to do it.

Did you read : https://www.olimex.com/wiki/A10-OLinuXino-LIME ?


I've been through the manual and the wiki, but no luck there.

Enabling eth0 doesn't make a difference, the boot process doesn't appear to go far enough to get a lease.


August 24, 2014, 10:48:51 pm #3 Last Edit: August 24, 2014, 10:50:50 pm by JohnS
Is it even set for DHCP?

If you don't get any console output something is very wrong.  Swapped TX/RX?  Failed to connect GND?  Wrong voltage levels in the cable?  Something...



August 25, 2014, 03:53:25 pm #4 Last Edit: August 26, 2014, 02:09:08 am by leniad
I have a board with the same problem, it was working fine, until I plugged in an USB pendrive, where it stopped working, and now it has the same symptoms you are describing. I'm trying to get another microSD to check if that's the problem. Does anybody know if there is supposed to be output in the UART0 even if there is no sd inserted? The speed should be 115200, right?

Edit: I managed to make the UART0 work (it was a faulty cable) and this is what I got:

U-Boot SPL 2014.04-10675-g44b53fd (May 23 2014 - 13:02:55)
Board: A10-OLinuXino-Lime
CPU: 1008000000Hz, AXI/AHB/APB: 3/2/2

U-Boot SPL 2014.04-10675-g44b53fd (May 23 2014 - 13:02:55)
Board: A10-OLinuXino-Lime
CPU: 1008000000Hz, AXI/AHB/APB: 3/2/2
MMC Device 0 not found
spl: mmc device not found!!
### ERROR ### Please RESET the board ###

It's not looking well :(


Found the problem - we had SD cards imaged for the A10S, not for the A10. Once I loaded the correct image, all is well.

Interesting to note that there is no output at all with a bad image - absolutely no error code, etc.


You did have output - you posted it!!



September 22, 2014, 03:38:53 pm #7 Last Edit: September 22, 2014, 04:28:40 pm by auraltension
What was the image you ended up using?  I'm having the same issue here with two boards I've just bought.

The boards are A10 LIME:

The power LED goes on solid, ethernet interface blinks, but no life visible anywhere else. Ho HDMI (tried multiple monitors and tvs), no ethernet coming up.

I'm trying the Debian SD card image from the Wiki Page 'a10_Lime_debian_3.4.90_release_3.img.7z'

I haven't been able to find a checksum anywhere.  The md5sum of the unpacked img is
2a7654ac7b8d765ff42bde081f70d846  /media/BB31-6969/a10_Lime_debian_3.4.90_release_3.img

I copied this to (and tried again with BS=4M also) to a Sandisk 4GB Class 4 (could this be an issue - it works for BeagleBone Black?) microsd using
dd if=a10_Lime_debian_3.4.90_release_3.img of=/dev/sdX

I'm using a 5V DC barrel connector, rated 1.5V.  I've tried a mini USB to my computer also but nothing happens.

I've tried using the UART connections (checked swaping tx and rx also) - using this cable from Adafruit (leaving red disconnected):

However I've never tried the cable on anything else so I can't rule that out.

I also mounted the sd card and edited /etc/network/interfaces to auto up eth0.  I tried both with DHCP and a static IP, connected to my switch and to my laptop.  No joy there either.

I'm presently downloading the android image to give that a whirl.


Ugh. I actually running an A20.  That'd no doubt cause some issues!

As soon as Google allows me to download an A20 image (Sorry, you can't view or download this file at this time.) I'll give it a try.


i have the same problems with one A10 lime (Led Power green Ethenet blink), but no up... i buy a serial usb cable today and i test it...


October 25, 2014, 02:16:08 am #10 Last Edit: October 25, 2014, 02:17:52 am by otyugh
I have the exact same symtomes.

I don't think it's related to my setup, because I did made it work a while back, and I had serious glicthes (the whole memory was going "read only" randomly after a few hours of use).
Now I guess something is broken, somehow ; I've tried debian's images and android ; green light goes, but nothing appears on the network (despite /etc/network/interface being setup), and no display at all (even if set manually chrooting it before).

So well. I have no clue ; I'm looking forward your own debuging :p
I'm gonna try some other microSD format to be sure, but I don't think it's the reason.


What's the memory speed setting for these boards? Is it possible that it is too high?

I run the A20 with Android and the original build files where using too nigh a speed setting and it often crashed. Lowering this solved the problem and now the system is ultra stable.


Entirely possible it's an unsuitable image being run, with bad memory timings or bad voltages from the PMU that may even cause damage.



I'm personaly using an olimex power supply, and microSD that "just work" on the A20. I tried several images (versions 2, 3  of debian, and the 1 of android) ; all the same. The version3 of debian is the only to get the green led lighting up, though, but all the same ; no IP up on the network (using nmap), and nothing at the screen.
Well, I'm mostly trying to do vodoo dance without this serial usb cable ; I hope mrcotcot will come up with something.


You need an image that's carefully created for the chip and the particular board and its memory etc or else you can expect problems.

The timings, pins, CPU kind, PMU (if any) kind, etc must all match.  They need to be right in u-boot and th kernel etc.

Many problems are caused by using a wrong image.