Olimex 7" LCD with Resistive touch and Android

Started by dave-at-axon, September 25, 2014, 05:32:40 pm

Previous topic - Next topic

dave-at-axon

September 25, 2014, 05:32:40 pm Last Edit: September 30, 2014, 09:02:21 am by dave-at-axon
For those keen to run Android on the A20 I just posted the changes needed to my source to get it to work with the Olimex 7" LCD.

http://axonjakarta.wordpress.com/2014/09/25/using-the-default-7-lcd-from-olimex/

If you find any issues let me know here or on the blog. :)

[UPDATE] I have found the issue of no calibration. The blog at the bottom has the additional information you need.

gvi70000

Hi Dave,

Thank you for the tutorial.
After I've follow your steps when i tried to build the image i got this error

Import includes file: out/target/product/olinuxino-a20/obj/EXECUTABLES/dalvik-vm-unit-tests_intermediates/import_includes
make: *** No rule to make target `device/softwinner/olinuxino-a20/modules/modules/fusion_F0710A.ko', needed by `out/target/product/olinuxino-a20/fusion_F0710A.ko'.  Stop.

Then i have searched in all lichee folder references for F0710A and i commented the lines/blocks where it was present and i got a bootable image but again without the TS. Is there any thing else to change except what you described in the tutorial?

dave-at-axon

Ah, your kernel mustn't be building the fusion driver.

Open the olinuxino-a20.mk file in the device/softwinner/olinuxino directory. (I think that's right)

Remove or comment out the line that that has the fusion driver and remember to remove the \ from the end of the line above.

I'll update the blog this weekend for those who don't build the fusion driver.

gvi70000


dave-at-axon

I'll check the build tomorrow and let you know but I think it is either part of the driver or still in there.

dave-at-axon

Quote from: gvi70000 on September 28, 2014, 12:00:14 pm
Did you remove the LCD calibration utility?


Ah, I recall now. I disabled the build so that this is not included. Let me track down where in the build it should be.

In the device/softwinner/common/packages there is a TSCalibration2 directory.

This needs to be added to the PRODUCT_PACKAGES +=

Let me see if I can find out what you need to add and where.

dave-at-axon

Sorry to all those who have been trying to get the resistive touch working. I updated the blog but here is the stuff about the TSCalibration2 file missing from the build.

Open the olinuxino-a20.mk file in the device/softwinner/olinuxino-a20 directory and insert the TSCalibration2 file here. It will autostart when Android starts if there is no calibration data.

PRODUCT_PACKAGES += \
gps.exDroid \
TSCalibration2 \
TelephonyProvider


gvi70000

Hello Dave,

So far i have succeeded with
- add RTL8188EU driver
- change back the LCD to default
- change back to rtp driver
- add calibration
- enable gpio needed by my applicaton

I still have two more questions

I have change the image from the media folder bootlogo.bmp and also initlogo.bmp but the Axon logo is still on when rebooting or power on. Is this image stored as binary? I saw two files with an array for bootlogo in the source.

Where i can change the time for lcd on in the source? I can change it in Android after i write the image, but is ennoing at the beginning

PS> What changes can i make without rebuid the whole image?

dave-at-axon

Good work.

The logo that is displayed as AXON is the initlogo.rle one on the device/softwinner/olinuxini-a20 directory.

The BMP is just my reference for it. :)

You need a couple of image converters to create it and I have forgotten how I did it. It was a 2 step process as I remember and the file has to be exactly 800 x 480 and a certain RGB format which is what took me a while to figure out. I should have written it down. :)

I'll see if I can work out how to do it again and then add it to the blog.

In the meantime, if you grab the original initlog.rle from the Olimex source, you can use that for now.

gvi70000

I have tried to use ImageMagic and also Photoshop to create the rle file. Can you tell me the software used by you to make the rle?

MBR

IIRC, the RLE files are a subset of the Windows Bitmap format (BMP), which is a run-lenght encoded 4bpp or 8bpp (16- or 256-color) bitmap with a palette. So you (probaly) can save a .bmp image in such format and just rename it to .rle (but you may need to keep the pallete intact).

tintu

Hello dave ... ,
I followed the tutorial for my 4.3 inch resistive LCD .
My fex configuration is as follows

[rtp_para]
rtp_used = 1
rtp_screen_size = 5
rtp_regidity_level = 5
rtp_press_threshold_enable = 0
rtp_press_threshold = 0x1f40
rtp_sensitive_level = 0xf
rtp_exchange_x_y_flag = 0

and all the other things are same as your post...
But an error comes saying "Unfortunately system UI has stopped".
What will be the reason?