Welcome, Guest

Author Topic: mplayer on A10 lime and  (Read 2158 times)

habib

  • Newbie
  • *
  • Posts: 11
  • Karma: +0/-0
mplayer on A10 lime and
« on: September 17, 2014, 07:36:40 PM »
Hi all !

Very surprinsing that mplayer requires so intensively the CPU on the A10Lime Board. Allwinner claim that it's a 1GHZ proc ...!

  PID USER      PR  NI  VIRT  RES  SHR S  %CPU %MEM    TIME+  COMMAND           
 1964 habib     20   0  119m 8872 6264 R  62,8  2,2   0:08.16 mplayer           
 1893 habib      9 -11  149m 4016 2920 S  17,1  1,0   0:40.48 pulseaudio       
 
....

habib@my_limeboard:~$ uname -a
Linux my_limeboard 3.4.103+ #1 PREEMPT Tue Sep 16 16:50:02 CEST 2014 armv7l GNU/Linux

habib@my_limeboard:~$ cat /etc/debian_version
7.6

How is it possible to improve this ? Most of boards on the market based on a ARM926 (armv5) are decoding mp3 files with mplayer with rather best results (about 23% CPU usage)

Best regards,


MBR

  • Sr. Member
  • ****
  • Posts: 256
  • Karma: +19/-0
Re: mplayer on A10 lime and
« Reply #1 on: September 18, 2014, 07:33:15 AM »
Try it without the PulseAudio by -ao alsa (or something like this). PulseAudio is a hungry desktop beast, not very suitable for embedded-like systems.

habib

  • Newbie
  • *
  • Posts: 11
  • Karma: +0/-0
Re: mplayer on A10 lime and
« Reply #2 on: September 18, 2014, 10:16:47 AM »
Try it without the PulseAudio by -ao alsa (or something like this). PulseAudio is a hungry desktop beast, not very suitable for embedded-like systems.

Hello,

Don't sure Pulseaudio is a beast as you say although you're probably right about non relevant for embedded sys like a10 lime. Quite sure pulseaudio is not a reason why mplayer consume 60% or more of CPU time on a 1GHz armv7 machine for just decoding a 320Kbits/s mp3 file.

FYI i just make the same thing on a old i.MX53 board (with pulse audio) and mplayer+pulseaudio consume 16% CPU max. i.MX53 compare with a10 are based on the same armv7 core.

Please could you make same thing on your platform a10 lime if you have one.

Initially i wanted to evaluate the a10 capabilities for building microphone+audio line inuts for an audio streamer system.

Best regards, Habib.

habib

  • Newbie
  • *
  • Posts: 11
  • Karma: +0/-0
Re: mplayer on A10 lime and
« Reply #3 on: September 18, 2014, 02:27:59 PM »
Try it without the PulseAudio by -ao alsa (or something like this). PulseAudio is a hungry desktop beast, not very suitable for embedded-like systems.

[SOLVED]

In fact the board has running with "on demand" performance ... for debian users on a10 lime i suggest to install cpufreq package and make this :
cpufreq-set -d 1GHz

cpu usage is now

  PID USER      PR  NI  VIRT  RES  SHR S  %CPU %MEM    TIME+  COMMAND                                                                                                                                       
 1921 root      20   0 46208 8604 6164 S   8,9  2,1   0:02.62 mplayer 

Furthermore the A10 chip temperature is quite low compared with my old i.MX53 board ! I will measure power consumption later.

Best regards, Habib.