device - Processor identification problem

Started by itzkul, August 27, 2014, 08:29:56 PM

Previous topic - Next topic


So far I have used Microchip's pickit3 unit, and everything worked  well. I work with the Pic18fxx family.
When I plug a PCB that already worked with Microchip's pickit3 (and it was all right)  the new Olimex pic-kit3 dosn't idetify the device well.

For example:
- while working with PIC18LF46K22 the identification is 00005420 instead of 00000000
- while working with PIC18F85K22 no identification, and the MPLAB stay in infinity "connect" loop

I'm working with MPLAB 8.6
I connected an external power supply of 12V to the Olimex pic-kit3.
I I'm ausing the same [as I used with Microchip's pickit3] cables to connect to the PCB.
Can anyone help ?


Hello itzkul,

Double check if the micro-controllers are properly powered.

Also very often the connections get mirrored. Double check each signal and the cables (are they mirrored, should they be mirrored).

Best regards,
Technical support and documentation manager at Olimex