OLinuXino Micro + Aten UC-232A USBtoSerial

Started by idragoev, November 14, 2012, 05:31:25 PM

Previous topic - Next topic


I have on USB to Serial from ATen (UC-232A) and I want to use it with the OLinuXino Micro. However, whenever I connect it to the board, the board stops and does not want to boot. If I disconnect it it is working just fine.

Any Ideas what should be the problem and how can I solve it?

P.S. With the USB cable we have from Olimex it works.



Good evening (here in paris)
Please, precise your system (sdcard origin)
could you plug your adapter in any linux host and use dmesg to know Vendor & product Id.
I experience that:
1) of course, you need a driver (module) matching Ids (none are included in most distributions)
2) I tried (see another post) a wrong version of Archlinux (link on olinuxInoMaxi web page) where ttyAMA0 was misspelled  as ttyAM0 (in /etc/inittab) and not working.
3) since you have debug access, boot, and when you have prompt for login, PLUG your usb-rs232, watch the message (Vendor Id and Model Id, then if is allocated to a new line /dev/ttyUSBx ).
If you see Ids but not /dev/ttyUSBx, the reason is that no driver was found matching Vid:Pid.

However it may be a lot of other causes.


Hi, flavigny,
and thanks for the prompt reply.

What we have here is not driver/Linux problem: I have the correct drivers, the USB is recognized, I have working OLinuXino that I can see using another USB-UART cable we have from Olimex.

I'm considering may be an electrical issue since I use only 3 wires - Tx, Rx, GND and restart is when I connect the OLinuXino to the USB-Serial cable.



Have you considered flow control (Olimex cable give DTR on), others need to set the emulator to "no control".
(read thread: http://tech.groups.yahoo.com/group/olinuxino/message/2049 closed by: http://tech.groups.yahoo.com/group/olinuxino/message/2048 )
I hope it will aid.



I wathch model on Aten web site, I see:

the db9 plug is to be connected to a modem!

could you check the voltage on rx and tx pin
it is a TRUE rs232c connector (with +/- V) and not a TTL one (0/+)


it seems you are right!

I used with another board ARM11 from china and it worked just fine.

Thanks flavigny!