wxPython

Started by ebelouet, June 26, 2014, 04:09:06 pm

Previous topic - Next topic

ebelouet

Hi,

Anybody try wxPython librairy with Python or solution to use graphic with Pyhton on A10 board Linux ?

Sincerely
Eric

martinayotte

I didn't try wxPython on Olimex board, but I used a lot of PyQT ...

ebelouet

thank for answering, so if it's for x86 cpu, I will run on A10 ?

ebelouet

I try this sudo apt-get install python-qt4 pyqt4-dev-tools but I have mistake, anybady have got solution

jlucius

Quote from: ebelouet on June 26, 2014, 06:50:56 pm
I try this sudo apt-get install python-qt4 pyqt4-dev-tools but I have mistake, anybady have got solution


What error are you getting?

All the graphical python wxPython or pyQT should run on the board without problems. you just have to get the right packages.

martinayotte

On A20, if I remember, I've simply install the "python-qt4", nothing else needed since it should also install all required dependencies.
(I did the same a year ago using my older A10S)

ebelouet

Hi,

Thank but I have this error :

Failed to fetch http://ftp.debian.org/debian/pool/main/p/python2.7/libpython2.7_
2.7.3-6_armhf.deb  404  Not Found [IP: 130.89.148.12 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-mis
sing?
where is mistake, I make this sudo apt-get install python-qt4?

Sincerely
Eric

MBR

Try download it from a mirror. Or try different DNS server (it may be a network problem).

martinayotte

Maybe your package lists are outdated. Try to do an "apt-get update" before doing "apt-get install".