Logitech K400r keyboard not working

Started by martinib, June 25, 2014, 10:34:29 am

Previous topic - Next topic



I tried connecting the Logitech K400r keyboard to the LIME, but this is not working.

I use the latest debian image a10_Lime_debian_3.4.90_release_3.img.

lsusb recognize it as ID 046d:c52b Logitech, Inc. Unifying Receiver.

Is this a missing driver in the kernel?

Ideas how to get this working is very much appreciated. Thank you.


What does the kernel say when the device is plugged? (clear the message buffer with dmesg -c (as root), plug it, wait a while, capture the output of dmesg)



I got an A20-OLinuXino micro board last days and tried to connect it to my Logitech K400r keyboard.
Same thing, keyboard is not recognized, however, my cordless Logitech Click! PLUS mouse is recognized successfully.

I tried the procedure from MBR:
dmesg gives the following info after plugging the k400r keyboard:
[878.731362] ehci_irq: port change detect
[878.955500] ehci_irq: port change detect
[879.015606] The port change to OHCI now!
[879.318286] usb 3-1: new full-speed USB device number 2 using sw-ohci
[879.601696] logitech-djreceiver 0003:046D:C52B.0004: claimed by neither input, hiddev nor hidraw
[879.618537] logitech-djreceiver 0003:046D:C52B.0004: logi_dj_probe:hid_hw_start returned error
Concerning Logitech: Linux OS is not supported for K400r.
However, I only need basic functions of the keyboard.

Thank you very much for help, regards


It seems that the keyboard is not recognised as a standard HID device. I'v read somewhere about keyboards and mice, which work only after a specialised driver is installed and some magical initialisation sequence (or maybe firmware upload) is performed. This keyboard is probably one of them. There are three possibilities:

  • The keyboard may be supported by Linux after all (and Logitech marketdroids don't know that), but it needs a specialised driver. Maybe you will have to build a custom kernel with all USB input devices enabled or you need some specialised utility to switch the keybouard into the HID mode (maybe modeswitch ?)

  • The keyboard is not supported by Linux, but if you send the correct "magic" into it, it will start to behave as a normal HID device. You may try to eavesdrop the initialization sequence and recreate it in Linux. This is a quite complicated and you will need either some hardware to perform the eavesdropping, or a virtualised machine running a OS with a working driver and a USB monitor on the host side.

  • Same as above, but the keyboard will never switch into the HID mode. You will need to write a custom driver for it. Even more complicated than previous point.



had the same problem, but I was able to fix it, I activated the hidraw and hiddev options inside the kernel:

Device Drivers -> HID Devices -> Generic HID Support -> /dev/hidraw raw HID device support
Device Drivers -> HID Devices -> /dev/hiddev raw HID device support


Thank you for this information.
I was glad to find this hint too, one week ago, on the sunxi home page on "tutorials / Logitech".

In the meantime, I had compiled my kernel with the configuration settings you mentioned and ... my K400r is working.

Thank you all for your contribution