Unable to enumerate STM32-P405 USB as VCP device

Started by saul01, June 30, 2014, 09:08:54 PM

Previous topic - Next topic


Has anybody has had success configuring the STM32-P405 as Virtual Comm Port device?
This is in short what I am doing:
1. Using OTG_FS configuration
2. Have a project define HSE_VALUE = 8000000 (so it runs the CPU at 168 MHz).
3. Configure D+ and D-
4. Configure the "DISC" pin and set it low.

When the board boots it only gets two interrupts, the wake-up and Suspend interrupts, but nothing more.
Any ideas?

Thank you.

Saul R.


More details to keep the interest up :)

-----|- +5V; no connection to V_sense; V_sense is disabled.
USB  |- D+; connected
Conn |- D-; connected
     |- Gnd; connected

ID, SOF and V-Sense are all not enabled.

I have the same code working for the Discovery board (from ST), but when tried to port it to the P405 board (Olimex), I only get two interrupts but nothing else; the PC just says that there is a problem with the connected USB device.

Anybody has an example of USB-VCP with this Olimex board?

Thank you.


A thought: someone may wonder which of the many Discovery boards you have it working on?

They may also wonder what the actual code is?  (Don't know if a ZIP/RAR can even be attached.)

Is there a simpler variant of ST code (I suppose non-OTG) that may work (I recall there is) and have you tried it?