imx233 Olinuxino-Mini-(Wifi) can't boot

Started by danko, June 16, 2014, 01:22:23 am

Previous topic - Next topic

danko

Hi,
after i get my olinuxino i would like to try first boot up a sample system and look around, but looks like it's more difficult as i first think!

I found a tutorial in the webshop and prepared the SD card as written.
https://www.olimex.com/Products/OLinuXino/iMX233/_resources/OPEN-EMBEDDED-README.TXT
i apply "sync" after write "imx233-Olinuxino.img" to first partition and copied the files then used "umount" to detach the card.

i used 9V@2A regulated (to 2A there is 9V at the output) supply to power the board and serial cable to observe what's happening:



HTLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLFC
PowerPrep start initialize power...
Battery Voltage = 0.03V
No battery or bad battery                                       detected!!!.Disabling battery                                   voltage measurements./r/nLLCMay 11 201215:26:EMI_CTRL 0x1C08


and writes this infinitely on the console.

in this version of system prepare i have no more idea what can i do,so i tried other:
http://www.jann.cc/2013/02/04/a_new_image_for_the_imx233_olinuxino.html
http://www.jann.cc/2013/02/07/u_boot_for_the_imx233_olinuxino.html
compiling kernel and u-boot, placed the uboot: dd if=u-boot.sb of=/dev/mmcblk0p1 bs=512 seek=4, copied the base Arch system and kernel, tried to start but now write the console "HTLC" infinitely.

In first case looks like "something" start work but i don't know what exactly contains that 16MB "imx233-Olinuxino.img" image, and i exactly don't know how the boot process work (other hand: i don't know how can i create working bootloader or debug why unable to work)

Thanks for help.

danko


mbergmann

June 20, 2014, 10:44:51 am #2 Last Edit: July 04, 2014, 02:48:26 pm by mbergmann
It's the register of the external memory interface (EMI).

Your UART debug line is incomplete, the line with the EMI looks like:

EMI_CTRL 0x1C08404 init_ddr_mt46v32m10

saying that the EMI register is set to 0x1C08404 and the memory is initialized by the bootlet function init_ddr_mt46v32m10. If you system reboots during this initialization I assume it can not initialize the RAM.

Did you tried with a different power supply (e.g. 6V)?

Regards

Mike