No ethernet with kernel 3.12.13, Olinuxino Maxi

Started by jomag, April 17, 2014, 03:34:37 PM

Previous topic - Next topic



I've used Olinuxino with the default kernel setup of Freescale BSP before without any problems.

But when I created a custom kernel configuration using menuconfig networking does not work anymore.

If I understand it correctly I should use the SMSC95XX driver with this board, so I made sure CONFIG_USB_NET_SMSC95XX is enabled. But after booting "ifconfig eth0 up" fails:

ifconfig: SIOCGIFFLAGS: No such device

I've tried "ifconfig usb0 up" with same result.

There is only one line in dmesg about this driver:

usbcore: registered new interface driver smsc95xx

What could I be missing?


Here's the complete dmesg:

My kernel configuration:

(I found no no way to attach files here...?)


I don't have experience with this board but probably CONFIG_SMSC_PHY should also be enabled.


Quote from: progmetalbg on April 17, 2014, 04:19:11 PM
I don't have experience with this board but probably CONFIG_SMSC_PHY should also be enabled.

I tried but it made no difference. Also, shouldn't CONFIG_USB_NET_SMSC95XX be dependent on CONFIG_SMSC_PHY if it was needed?


Check Jann's blog post for compiling Linux 3.xx for iMX233-OLinuXino:
Device Drivers  --->
  [*] Network device support  --->
    USB Network Adapters  --->
      <*> Multi-purpose USB Networking Framework
      <*>   SMSC LAN95XX based USB 2.0 10/100 ethernet device

It's a bit old put probably still valid.
Also .config for 3.12:
related to this post:


I have read Jann's blog before and I have the drivers you listed enabled.

I tried to use the .config posted above, and it worked!

However, I have compared my .config with that one and I really can't find any differences that should matter. I have tried to enable everything that remotely looks related to networking or usb, but to no avail... Now I'm testing to enable things that does not seem even remote related, cause there must be a difference since that .config works and my doesn't, all other things equal.

I would be happy if anyone would like to take a look at my .config.


Finally found what I was missing: CONFIG_USB_CHIPIDEA and CONFIG_USB_CHIPIDEA_HOST.