A10 LIME - can't enable network

Started by pfandfrei, April 04, 2014, 12:27:29 pm

Previous topic - Next topic


first of all: I'm a real beginner with debian

I got my A10 a few days ago and tried the image from here: https://www.olimex.com/wiki/A10-OLinuXino-LIME#Linux

Everything seems to work fine except network. I always get the message "the network connection has been disabled".
Tried to modify network at LXDE desktop => no success
Tried to modify /etc/network/interfaces => no success

After manual configuring eth0 in console the adapter is available, but I want to init eht0 at startup.

Any ideas what I can do?


What's in your /etc/network/interfaces file?
Are you using a fixed address or dhcp?
If dhcp, you should have something like:
   auto eth0
   iface eth0 inet dhcp

Does your gateway block unknown hardware address? Maybe it's not letting you connect?
You may also want to check the /etc/resolv.conf file. It should have the address of your gateway in it. By default it has probably the wrong subnet.


Sorry for the late answer, did not realise that there is no notification in this forum ...

Meanwhile I solved the problem with editing the NetworkManager.conf. I changed the 'managed = false' entry to 'managed = true' and everything is fine now.

Thanks for the reply.