Welcome, Guest

Author Topic: Disable of LXDE  (Read 2769 times)

djrose

  • Newbie
  • *
  • Posts: 21
  • Karma: +0/-0
Disable of LXDE
« on: February 25, 2014, 02:51:40 PM »
I'm having problems with the disable of LXDE.

I am using a build of Linux carried out with the instructions from:

http://olimex.wordpress.com/2014/01/15/building-debian-linux-bootable-sd-card-with-hardware-accelerated-video-decoding-and-kernel-3-4-for-a10-olinuxino-lime/

On that build, I am now running a full screen QT application on an LCD and want to disable LXDE.

So, thinking I was at last becoming familiar with Linux, I executed the command:

Code: [Select]
update-rc.d slim remove
On a reboot, LXDE does not start - But I have noticed a couple of problems:

1 - On each boot, the following is reported:

Code: [Select]
chmod: cannot access `/dev/mali': No such file or directory
startpar: service(s) returned failure: rc.local ...

2 - The partition holding boot.scr ( /dev/mmcblk0p1 ) is not mounted and so the files there are not directly visible.

Can anyone throw any light on what is happening here?

lubod

  • Newbie
  • *
  • Posts: 15
  • Karma: +1/-0
Re: Disable of LXDE
« Reply #1 on: March 09, 2014, 08:38:18 PM »
Taking a shot in the dark since I haven't used that disk image and have no way to reproduce the symptoms.

Something in the boot sequence is trying to do chmod to /dev/mali and failing. Maybe this 'startpar service'? Check rc.local (probably in /etc).

OR

do
Code: [Select]
dmesg >> ~/dmesg_output.txt in a terminal, it will dump all the events from when you power it on to when you execute the command that it deemed worthy of logging (like plugging in USB devices, for example) in a text file named dmesg_output.txt in your home directory.

HTH

djrose

  • Newbie
  • *
  • Posts: 21
  • Karma: +0/-0
Re: Disable of LXDE
« Reply #2 on: March 10, 2014, 10:35:48 AM »
Thanks for your response lubod.

A step forwards. You were right. rc.local was attempting to access /dev/mali and failing. Commenting out that line removed the failure during boot.

Unfortunately, it doesn't fix the problem I'm seeing with mounting.

I'm clearly missing something - So will continue to look.

djrose

  • Newbie
  • *
  • Posts: 21
  • Karma: +0/-0
Re: Disable of LXDE
« Reply #3 on: March 10, 2014, 11:40:36 AM »
Adding an entry in /etc/fstab got the /dev/mmcblk0p1 back.


lubod

  • Newbie
  • *
  • Posts: 15
  • Karma: +1/-0
Re: Disable of LXDE
« Reply #4 on: March 10, 2014, 03:05:39 PM »
Sorry I totally missed the part about mounting /dev/mmcblk0... (What can I say, since it wasn't inside the code snippet, I thought it was a comment on your part, but not part of the output) :)

If no LXDE is one of your primary goals, you might try a disk image with no LXDE, rather than removing it.
https://romanrm.net/a10/debian

No affiliation with the developer, I just  used it myself and am very happy with it.
120MB download instead of 1.1GB, as close to stock Debian 7 Wheezy with no GUI (add whatever you want on top, but nothing to remove!)

Glad you got it sorted out too, and thanks for the karma.
« Last Edit: March 10, 2014, 03:12:21 PM by lubod »