[Solved:] ArchLinux (as mentioned on Olimex web page) does'nt start

Started by flavigny, November 05, 2012, 04:53:20 pm

Previous topic - Next topic



on 20121108, Oooops, zgyarmati give the way; it was a mistake in original /etc/inittab file, see new post, change ttyAM0 to ttyAMA0

I left this topic for information purpose.

After reading the answer by Kean below, I tried http://archlinuxarm.org/platforms/armv5/olinuxino and it runs.

on November, 7, 2012, I have retried, the Olimex way, there is no more error.
I apologize if it was a mistake of mine.
May be the "latest" has changed ?

Today, I receive USb Dongle (TP-Link, Wn722) so I moved to Archlinux for trying it.
I have loaded sdcard as indicated page: https://www.olimex.com/Products/OLinuXino/iMX233/_resources/ARCH-README.TXT
My OlinuxIno-maxi start booting, but freeze, here after the last lines:

:: Mounting Local Filesystems                                            [DONE]
:: Activating Swap                                                       [DONE]
:: Configuring Time Zone                                                 [DONE]
:: Initializing Random Seed                                              [DONE]
:: Removing Leftover Files                                               [DONE]
:: Setting Hostname: oli                                                 [DONE]
:: Saving dmesg Log                                                      [DONE]
INIT: Entering runlevel: 3
:: Setting MAC address to d2:74:d7:73:15:d6                              [DONE]
:: Starting Syslog-NG                                                    [DONE]
usb0: link up, 100Mbps, full-duplex, lpa 0x45E1
:: Starting Network                                                      [DONE]
:: Starting OpenNTPD                                                     [DONE]
:: Mounting Network Filesystems                                          [DONE]
:: Starting crond daemon                                                 [DONE]
:: Starting Secure Shell Daemon                                          [DONE]
INIT: Id "s0" respawning too fast: disabled for 5 minutes
INIT: no more processes left in this runlevel

(I have not yet plugged Usb wifi adapter)
no better if I remove ethernet cable.

What is wrong ?


Can you check what name your serial port got from the kernel (should be visible eariler in the boot output)? And also a cat /etc/inittab might be useful.
Probably you have to modify your in inittab the getty line to use ttyAM0 (or whatever name your serial port got)
Zoltan Gyarmati


You might want to try the instructions under the Installation tab of this page

These instructions have worked fine for me.  The instructions you linked to might be a bit out of date.