Production inconsistencies on IMX Maxi boards

Started by VinceGeisler, December 07, 2012, 10:50:54 pm

Previous topic - Next topic

VinceGeisler

Im working on a project to remote control some equipment on our repeaters sites. the hardware chosen was a Imx Maxi and a Mod-io board. We built up the prototype in the lab, and ordered spares of each board in case of problems in the field. it appears both Imx boards failed out of the box. The first one, was used for our development, no modifications to the board at all were done. Its entirely as it came out of the box. We noticed upon installing the devices, that the first Imx board was able to talk to the MOD-IO board, but the networking chip was unstable, sometimes starting up, sometimes not. seemed to depend of if you touched the case of the crystal while it was booting. touch case, it books ok, don't touch case, the oscillator doesn't start and nether does the network chip.

so no problem, that's why we always order spares.. i popped in the second board again from a sealed package, and this time the network started up, but i2c wouldn't communicate with the MOD-IO. so in the end it was a mission failure at a cost of several thousand dollars for man hours and helicopter access.

Upon returning to the Lab, we noticed something peculiar. it appears that one of the iMX boards was factory set to hardware I2C and the other to software I2C. This is unacceptable, as we need these boards to start in a known configuration, not random config.

what is the official default setup? It appears that SW-I2C is default on the layout, i have no idea why someone at the factory would have reworked it to be HW-I2C, but unless we can have some assurance consistancey on these parts, its going to be impossible to go forward with the project using Olimex boards.


olimex

Hi
I'm sorry for your troubles
at the very beginning the imx233 boards were shipped with I2C set to software mode, later we moved the jumpers to hardware I2C, this should be documented in the users manual. I guess one of your boards is from early produced batch, as since september all boards we ship are with I2C set to hardware

our boards have lifetime warranty for manufacturing defects and components, if you think your board problems are caused by manufacturing defect or component you can send us e-mail and receive RMA to send it back for inspection.

Tsvetan

VinceGeisler

Tsvetan,

Thanks for the reply, the first board im going to have to rma as i cant find a reason for the oscillator problem that is obvious. the second one with the I2C problem i can mod, if that wont violate the warranty. 

I do like your work, as someone who had been designing boards for 20+ years, you can tell by looking at the board, the skill level of the designer. I spent 10 years designing avionics, so as a result i have strong opinions about QC and such. for me solder pads for option selection is a big no-no, its simply too easy to miss this in QC. Though they are slightly larger, i find 1mm pich jumpers best for this sort of thing, it calls attention to the fact that there is a configuration option located there. manuals are hell to read with thick arctic mitts on ;-). Again that's just the opinion of an designer who spent entirely too much time in a high stress job :-)

my best piece of advise to another designer is to read "The Design of Everyday Things; Donald Norman". it was required reading in our shop, and teaches you the mindset of self documenting intuitive design that leads the user to the correct decisions/actions by default.

In the end I'm not upset, I've been in the business long enough to know if it isn't one thing it'll be another that trips you up and the need to budget for it.. Just wanted to call your attention to a potential problem.

cheers

vince