Welcome, Guest

Author Topic: Problem with LCD 4.3TS but only in X  (Read 2341 times)

lbalas

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
Problem with LCD 4.3TS but only in X
« on: February 12, 2014, 12:06:48 AM »
Hi All,

I bought an A10 Lime board with 4.3 LCd screen with touch screen. First time I tested it with an A20 board and the LCD and the TS worked properly without any setting or ts-calibrating.

After that I connected this LCD to A10. The display worked fine, but the TS calibration was wrong. I calibrated with ts_calibrate, and it worked properly on console screen.
I tested it on X but the calibration still was wrong.

Did somebody meet with this problem?
What can I do to resolve it?

Please help me!

Thanks in advance:

lbalas
« Last Edit: February 13, 2014, 01:30:39 AM by lbalas »

djrose

  • Newbie
  • *
  • Posts: 21
  • Karma: +0/-0
Re: Problem with LCD 4.3TS but only in X
« Reply #1 on: February 12, 2014, 11:11:06 AM »
I have a 7 inch LCD and had the same problem.

ts_calibrate stores the calibration values in /etc/pointercal

LXDE takes calibration values from /usr/etc/pointercal

I'm sure someone would be able to give information to configuration faults, but my quick solution was simply to copy the good /etc/pointercal to /usr/etc/pointercal


lbalas

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
Re: Problem with LCD 4.3TS but only in X
« Reply #2 on: February 12, 2014, 02:43:12 PM »
Hi djrose,

thank you very much your fast answer.
I will try it at night and I will inform you about the result.

Balas

djrose

  • Newbie
  • *
  • Posts: 21
  • Karma: +0/-0
Re: Problem with LCD 4.3TS but only in X
« Reply #3 on: February 12, 2014, 05:20:48 PM »
I found a simpler way is just to edit the file:

Code: [Select]
/etc/environment
Change line:

Code: [Select]
TSLIB_CALIBFILE=/etc/pointercal
To:

Code: [Select]
TSLIB_CALIBFILE=/usr/etc/pointercal
Then reboot and recalibrate.


lbalas

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
Re: Problem with LCD 4.3TS but only in X
« Reply #4 on: February 12, 2014, 05:42:15 PM »
Thank you very much, both solutions are working properly with 4.3 LCD as well.  :)
You are great!


Balas
« Last Edit: February 13, 2014, 01:30:46 AM by lbalas »