Problem with LCD 4.3TS but only in X

Started by lbalas, February 12, 2014, 12:06:48 am

Previous topic - Next topic

lbalas

February 12, 2014, 12:06:48 am Last Edit: February 13, 2014, 01:30:39 am by lbalas
Hi All,

I bought an A10 Lime board with 4.3 LCd screen with touch screen. First time I tested it with an A20 board and the LCD and the TS worked properly without any setting or ts-calibrating.

After that I connected this LCD to A10. The display worked fine, but the TS calibration was wrong. I calibrated with ts_calibrate, and it worked properly on console screen.
I tested it on X but the calibration still was wrong.

Did somebody meet with this problem?
What can I do to resolve it?

Please help me!

Thanks in advance:

lbalas

djrose

I have a 7 inch LCD and had the same problem.

ts_calibrate stores the calibration values in /etc/pointercal

LXDE takes calibration values from /usr/etc/pointercal

I'm sure someone would be able to give information to configuration faults, but my quick solution was simply to copy the good /etc/pointercal to /usr/etc/pointercal


lbalas

Hi djrose,

thank you very much your fast answer.
I will try it at night and I will inform you about the result.

Balas

djrose

I found a simpler way is just to edit the file:

/etc/environment

Change line:

TSLIB_CALIBFILE=/etc/pointercal

To:

TSLIB_CALIBFILE=/usr/etc/pointercal

Then reboot and recalibrate.


lbalas

February 12, 2014, 05:42:15 pm #4 Last Edit: February 13, 2014, 01:30:46 am by lbalas
Thank you very much, both solutions are working properly with 4.3 LCD as well.  :)
You are great!


Balas