ScreenSaver or Power saving issues

Started by locobastos, January 22, 2014, 12:37:29 pm

Previous topic - Next topic

locobastos

January 22, 2014, 12:37:29 pm Last Edit: January 23, 2014, 05:53:37 pm by locobastos
Hello everyone,

I would like to disable screensaver and/or power saving on my A20-OLinuXino-MICRO with Debian Release 5 from Olimex.
My aim is to launch web site to follow something during so many hours. So I don't want it to run ScreenSaver or Monitor Power Saver.

I tried to change configurations in Applications Menu > Settings > Screensaver :
First, it says me  "XScreenSaver daemon doesn't seem to be running on display ':0.0'" and I cancel its launch.
By default, Screensaver mode is "Disable Screen Saver".

Then i tried to change in Applications Menu > Settings > Power Manager :
unchecked "Monitor power management control"
On AC & On Battery's Monitor tab : All of trackbar (c# name) / slider (c++ name) are set to Never

Finally, i tried to change UPower file, on /etc/UPower/UPower.conf and set :
RunPowersaveCommand = false

Same for '/root/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-power-manager.xml' & '/root/.xscreensaver', all changes done don't change anything.

My screensaver run after 10 minutes of inactivity.

Can someone help me ?

Thank you.


locobastos

Thanks, i'll look about xorg.conf.d files, but your link is for SunXi system so i can't copy/paste code...

I'll post answer if i find it.

progmetalbg

AllWinner A20 is sun7i, A10 is sun4i, A13 is sun5i, A31 is sun8i, etc... and linux-sunxi.org is the wiki page where you can find useful info for your Allwinner based device written by the community.
If you don't want to modify xorg conf, there is another option:


QuoteYou can also forcibly disable DPMS at runtime (in X):

xset -dpms

...and/or make sure no screen-saver will kick in that would trigger blanking or some other undesired effect:

xset s off



locobastos

thank you for your help Progmetalbg,

I add on ~/.profile file these two lines, which solved my problem.

xset dpms 0 0 0
xset s off

now it works :)

thx !!!

locobastos

Yesterday, i didn't try what I did :

When I write these two commands in Termial Emulator, there is no problem :

xset dpms 0 0 0
xset s off


But now, when I write these two commands in ~/.profile file, and when I reboot, they don't change anything.

Of course, I tried to write in /usr/share/X11/xorg.conf.d/99-sunxifb.conf what progmetalbg's link say :
http://linux-sunxi.org/Binary_drivers#The_screen_go_off_and_don.27t_restart_until_reset

But on boot, xfce4 won't start, and "No screen found" error appear.

So my problem is not solved now...


progmetalbg

Instead of ~/.profile you can try putting the xset commands in ~/.xinitrc
https://wiki.debian.org/Xinitrc

locobastos

I tried in ~./xinit & ~./xsession,

both were not on my Olimex so i had to create these files.

After reboot for each file, nothing change.

Can someone say me that i'm not alone to have this problem ?

thx

locobastos

January 24, 2014, 11:49:51 am #8 Last Edit: January 24, 2014, 11:51:25 am by locobastos
I also tried to create an executable file : /etc/init.d/xset
in which i write these two commands :

xset dpms 0 0 0
xset s off


And i did

chmod +x /etc/init.d/xset
ln -s /etc/init.d/xset /etc/rc1.d/K02xset


Same as before, nothing change after rebooting...

taddo1705@gmail.com

Ciao.
Try this:

0) [optional step - only for accelerate test] change Application Menu > Setting > Power Manager > On AC > Monitor (tab):
set 1 minute in "Put display to sleep when..."
set 2 minutes in "Switch off display..."

confirm with button <close>

1) Create file /root/xset.sh:
sleep 60
/usr/bin/xset dpms 0 0 0
/usr/bin/xset s off

2) Change permission:
chmod +x /root/xset.sh

3) in Applications Menu > Settings > Session and Startup > Application Autostart (tab) "add" application /root/xset.sh

4) reboot

I use A20 with debian image release 5.

Now monitor is always on!

Ciao
Taddo