A10S-OLinuXino-Micro not booting ?

Started by Vincent, January 07, 2014, 06:42:17 PM

Previous topic - Next topic


Hi everybody.

I'm quite new here, sorry if I made a silly mistake  ;D

I just received an A10S today (no NAND) with a prebuilt debian (microSD).
I took it "as is" and plugged a power supply (5V DC) and an HDMI cable (to my working HDMI screen)... But nothing happens. Even after pushing "Power" many times, short and long pushes.

Did I miss anything or did I do anything wrong ?

Thanks for your help.



You have multiple options.

1) connect a RS232 (serial) interface to UART0 ( in the corner opposite to the power jack) and read if the boot process hangs up
2) connect ethernet and login to debian via ssh and check the logs

I didnt use the HDMI-Port so far, maybe you have to switch it on in the script.bin located in the small paritition of the SD-Card. You can build a new one quite easily from a premade .fex file you can find in the git repo i think. The tool you need for that is called fex2bin.


Hi Soenke, thanks for replying  :).

I tried 2) but no new devices appear on my router monitoring tool. Meaning I'm unable to get its IP and check if it correctly booted and/or try to connect to it through SSH.

My skills at electronic are quite limited but I'll try 1) though.

I read something about script.bin, indeed, but can't find it on my prebuild Debian (microSD provided by Olimex) (with find . -name "*.bin"). I'll look on the git repo and use fex2bin if I find a .fex file.

The script.bin is supposed to be put in /boot/ right ?

Thanks again.

Best regards.


It needs putting where the thing looking for it expects.  For U-Boot it depends how it is set up.  Commonly it loads it from the first partition but I don't see that as hard-wired.  It doesn't look in /boot on mine.

All info is in linux-sunxi wiki.



Hi all,

I create bootable microSD card with recommended prebuild image (debian) from olimex.

I insert card to A10S, connect HDMI monitor. Next connect power +5V to the board.

Monitor starts to blink and display message about refreshing is out of range (103 Hz).
LED1 is on when uSD card is inside. Without card, LED1 is off.

Can You help me with this?
(Sorry for my language)


if traffic-led is blinking, then it gets itself an ip. if not, it doesnt.
You can connect the SD-Card to another linux computer and read /var/log/syslog to see what happens at bootup and if the device gets link. And you can fix /etc/network/interfaces if it is broken somehow.

script.bin is normally on the first partition (fat16 or fat32, 20MB or something)

If you connect a serial console to uart, pay attention to use 3.3V. You probably kill the cpu if you use a 5V adapter.


Hi again,

My LCD doesn,t support standard display parameters
I connected board to TV and this solve my problem.

thanks to all


Hi everyone, I managed to boot the A10S. It simply was a problem of system image... I made a whole new debian copy on the microSD  (with the windows soft this time, Win32DiskImager or something like) and it worked. Surprisingly, using "dd" command on Linux didn't produce the same result.

Now I'm fighting against the kernel configuration because I need the usbserial module and CONFIG_USBSERIAL is disabled by default in the debian img provided by Olimex  :-\.

Thanks for you help.


Hello, it's me again, sorry.

Did anyone succeed on building Linux from scratch with A10S using gcc 4.8 ?

I followed this guide, step by step, line by line:

And the card is not booting with my just-created µSD card  :-\. The only difference I notice with the tutorial are the sunxi git repository versions, and the gcc version (they're using 4.6 [I guess], I'm using 4.8).

I'm following this guide right now http://olimex.wordpress.com/2013/10/28/building-debian-sd-card-for-linux-with-kernel-3-4-from-scratch-for-a10s-olinuxino-micro/
Which is almost the same but for Linux 3.4 (with different files). Perfect, as I was trying to make a 3.4 image :). I'll let you know with a new post if I failed.