Beginner problem, LPC-L2294 board in reset

Started by Bruce1, October 29, 2013, 02:28:15 PM

Previous topic - Next topic


I have a Segger J-link connected to a LPC-L2294 board. The setup is totally new, and I have minimal experience with JTAG, but am familiar with some other embedded platforms and development environments. When I powered the system up, the JTAG failed to connect, with the LED orange.  I posted the problem on the Segger forum and they came back with the following:
Orange: Target reset pin (pin 15 on the J-Link side) is detected LOW (active). Target is currently held in reset.

You are using an LPC2294 (ARM7) which can not be accessed while held in reset.
Please check your target connection / wiring.

The only wiring involved is the J-link connector which plugs straight into the ARM board, so that is unlikely to be the problem. I have two boards, and both show the same behaviour. The power supply is fine.

Can anyone suggest why the system is in reset? Is it pinning (sub-question) where can I get info on the board jumpers and their function? Or is there some sort of initialisation procedure that I need to go through to make the JTAG talk.

Thanks in advance.


The problem was power supply, I was initially powering the board with 4.5vac (as per schematic). A check with a scope showed a high level of ripple on the DC rails, when I replaced the PSU with a regulated 6VDC supply everything worked.

Could someone from Olimex please clarify what the power supply specs for this board are? Is it specified for US supply (60 Hz) but not Europe/Australia (50 Hz)? That seems unlikely, if it worked on 60Hz it would be pretty marginal. 400 Hz maybe (mobile supplies, typically square wave)?

The sooner something comes up on the wiki for this board the better!