July 25, 2024, 10:22:54 AM

STM32-E407 a few questions to olimex

Started by anotherbrick, October 23, 2012, 04:45:58 PM

Previous topic - Next topic


hello , In my existing PLC design
I want replace my old cpu board from futurlec with STM32-E407 board from Olimex

however I have some questions

1) I worked with STM32F103 before with RIDE7 IDE
there I could download my application code through USART1 from F103 with help of ST loader software
how can I download my appl. to this STM32-E407 board ?

2)is there an free IDE + compiler for this F407 CPU ?
which JTAG does it support?

3) ST offers an free TCP / IP with the name LwIP
can I run this software on your STM32-E407 ?

thank for the answers


Hello anotherbrick(inthewall I suppose),

Thanks for the interest in Olimex products.

1) The STM32 processor is mounted and routed according to all hardware precautions and USART3 is available for boot - you can see it near the schematic name in the bottom right part: https://www.olimex.com/Products/ARM/ST/STM32-E407/resources/STM32-E407_Rev_B1_sch.pdf. It lacks connector so you should use wires or you might use this one if the software you use permits: https://www.olimex.com/Products/Components/Cables/USB-Serial-Cable/USB-Serial-Cable-M/. There are a lot of considerations about the booting of this family of microcontrollers (you can boot from the USB also with the right program) so it will be better to check the official documentation: http://www.st.com/internet/com/TECHNICAL_RESOURCES/TECHNICAL_LITERATURE/APPLICATION_NOTE/CD00167594.pdf

2) At least two free choices:

2.1) Our programming software + any Olimex OpenOCD debugger - Olimex ODS + Olimex OpenOCD JTAG debugger (ARM-JTAG-TINY-H, ARM-JTAG-TINY, ARM-JTAG-OCD-H, ARM-JTAG-OCD) - the latest beta version can be found here: https://docs.google.com/open?id=0B7WHuNCASY8cTThQNk41QXhjTWs - it features a STM32-E407 example

2.2) CooCox IDE + OLIMEX COOCOX-JTAG debugger - CooCox is fairly popular and often updated IDE (especially among the asian developers) it can use both the popular ARM compilers. More info on their official web-site: http://www.coocox.org/. It also has support for our OpenOCD programmers mentioned in 2.1) but COOCOX-JTAG is a native COOCOX tool.

3) It is very likely it will run but would probably lack full functionality out-of-the-box (without adjusting the software according to STM32-E407 design). I haven't personally tested such an option.

Just want to add STM32-E407 is one of my personally favorite boards.

Best regards,
Technical support and documentation manager at Olimex


hello LubOlimex ( yes in the wall )

I have downloaded Olimex programming software

and installed in my computer ( win 7 home premium )

after starting Eclipse I tried to build

STM32-E407_blink_FLASH project

it gives following error:

**** Build of configuration Default for project STM32-E407_blink_FLASH ****

(Cannot run program "make": Launching failed)


Hey anotherbrick,

This error means that the IDE can't find the compiler. This might be due to a number of reasons but the two main ones are:

1) You have installed the whole package to a computer location which features "space" symbol. Unfortunately as most OpenSource tools the toolchain we have used is not very well supported in Windows so please reinstall to a location without "space".

2) For some unknown reason the install path wasn't added to your global variables PATH and the IDE can't find the compiler again. Please manually add the path to the compiler in environment variables (Right-click on My Computer -> Properties -> Advanced Settings -> Environment Variables; in the bottom frame - System Varables - scroll to PATH, mark it and click Edit if the PATH is added it should look something like: <DRIVE_LETTER>:\<INSTALL_FOLDER>\yagarto\bin)

Looking forward to your feedback.

Best regards,
Technical support and documentation manager at Olimex


hello LubOlimex

if I fix one error this time the next error shows up  :D

this time I got following ;
( I googled this below error ; some people faced it before
and suggested to play with windows system virtual memory sizes
I changed VM sizes ( made them the recommended size )
however the error didnot disappear )

can you help how to proceed ?

**** Build of configuration Default for project STM32-E407_blink_FLASH ****

make all
AllocationBase 0x0, BaseAddress 0x71590000, RegionSize 0x160000, State 0x10000
C:\OlimexODS\yagarto\bin\sh.exe: *** Couldn't reserve space for cygwin's heap, Win32 error 0
make: *** [obj/main.o] Error 1