SSH over Ethernet

Started by Vinayakj70423, July 20, 2013, 04:39:41 pm

Previous topic - Next topic

Vinayakj70423

Hi
I am a bit new to this processor.
Have been using Raspberry Pi for some time now.

I bought this board think that it would be possible to SSH  to it over Ethernet.

For my project, i need to be using the Android OS, and have some work done. Problem is, i don't have the USB-UART convertor, or an HDMI TV. I tried connecting the TV output providet to a noraml Analog tv, but no use.

Was wondering if it is possible to use SSH over an Ethernet connection in Android, as it is possible for Raspbery Pi.

Any help would be appretiated.

Vinayakj70423

Oh. speaking of Raspberry pi, got a serial connection to the A10s vie uart port.

I did not have usb-uart convertor, so i used my raspberry pi, as ethernet to uart convertor.

Still i think getting a SSH connection over ethernet is a better thing, compared to the circuis that i am doing right now.

Can someone please tell me how i can install ssh server for the A10s.

martinayotte

On Debian, here is the thread about enabling SSH :

https://www.olimex.com/forum/index.php?topic=1555.0

On Android, I'm not sure if this procedure will be enough, depending if SSHD daemon is present in Android image. If not you will need to compile it.

Vinayakj70423

searched high and low for sshd. could not find them..
Worst part is commands such as Wget, apt-get are not installed.
I guess i will look up compiling the server.
Hope i don't have to compile the whole image, found it to be a real pain.

martinayotte

Unfortunately, Android isn't a full fledged Linux, either you switch your project to Debian, or if you need to stay with Android, maybe you can give a try with some android application such "sshdroid.apk", which a application that you start from the android gui, then it allow you to get into ssh shell. you will probably wish to install some busybox.apk too.

Vinayakj70423

ok don't need the SSH anymore.

Android sdk in ubuntu allows using ADB to send shell commands.

The board used to come up as

???????????????????????????? no permissions

when i ran the ADB devices command.

But i got that fixed by following this link

http://stackoverflow.com/questions/9210152/set-up-device-for-development-no-permissions

Thanks for the help anyways.  :)