May 28, 2022, 10:11:47 am

Olimex ODS + ST-link/V2

Started by lopesjm, July 10, 2013, 06:22:21 pm

Previous topic - Next topic

lopesjm

Hi everybody,

  How can I use stlink/V2 with the Olimex ODS ? Is it possible ?

  thanks in advance
     Jorge

LubOlimex

Hey Jorge,

If you have a stand-alone stlink/V2 then it is possible but not out-of-the-box. You would need to add own debugger configuration (since there are ready configurations for Olimex-made debuggers only). Such configuration files might be found around the OpenOCD community (I believe there should be a ready cfg for stlink/V2 in OpenOCD anyway since it's quite popular debugger). You would simply have to add them in the interface.

If you have a built-in a board stlink/V2 (like in Discovery board, for example) then it is not possible since it has only SWD interface and SWD interface is not supported fully at the moment.

Best regards,
Lub/OLIMEX
Technical support and documentation manager at Olimex

lopesjm

Hi LubOlimex,

  I have both debuggers (The stand alone and the Discovery F4 board). My special interest is use of st-link/v2 stand alone with Olimex ODS. I try a how-to from ChibiOS
www.chibios.org/dokuwiki/doku.php?id=chibios:guides:stlink_eclipse , but I failed. I stopped in the second item "Creating a GDB Debug Configuration", because I don't know how to install the GDB Hardware Debugging extension in the eclipse.

  I thank any help to do it.
  Jorge

LubOlimex

Hey Jorge,

This should be explained here I believe: http://www.chibios.org/dokuwiki/doku.php?id=chibios:guides:eclipse2.

Still you can install our IDE and add only the debugger configuration for ST-LINK/v2 following the ChibiOS guides.

Best regards,
Lub/OLIMEX
Technical support and documentation manager at Olimex