A20-OLinuXino-MICRO-4GB shipped with wrong DDR3 chips setup

Started by rz2k, June 16, 2013, 01:48:52 am

Previous topic - Next topic

rz2k

Hello, I've purchased A20-OLinuXino-MICRO-4GB to help A20 porting going on by linux-sunxi and I have two hynix 256MB DDR3's instead of two 512MB Memphis on my board.

Other linux-sunxi developers got the version with 1GB (Henrik, Oliver, may be MRipard).

The page where I purchased it clearly says 1GB - https://www.olimex.com/Products/OLinuXino/A20/A20-OLinuXino-MICRO-4GB/ This was what I was paying for and also what I wanted to support in future (ONE version of  board for everyone). Now I have: SPL problems (it was hardcoded to 1gb), UART problems (hopefully, they are not connected to RAM problems, or board will not be supported by linux-sunxi) and many more bad stuff that can happen because of this.

You clearly shipped either wrong board or the very early experimental board (my board is 1:1 to shown on http://olimex.files.wordpress.com/2013/05/a20.jpg, dates in u-boot compile time is 16.05.2013).

I am not demanding anything (lost hope in this long ago), but this type of actions just kill my respect to Olimex, you divided this board community in two parts without saying anything at all. One will be supported, other will be dead. Please, dont become another chinese manufacturer.

Probably Best Regards,
Dmitriy.

olimex

Hi
this is unfortunate mistake :) we have build for internal use the very first 3 + 3 A10 and A20 MICROs with 2Gbit memory chips, then we continued with 4Gbit chip the rest samples we got.
So obiously you got one of these first 3 A20s with 512MB by mistake.
Do not worry we will send you one A20 with 1GB as soon as we have the new lot ready!
again sorry for this mistake, its not intentional
Tsvetan

rz2k

Yes looks like it was shipping/delivery mixup.
Got to work today and checked with a board that arrived to my pal - http://i.imgur.com/NvfOoFJ.jpg He got 1GB.

Thanks for sending the replacement Tsvetan! Topic can be closed.

Best Regards,
Dmitriy Beykun