Debian package problems - may be faulty board or software

Started by David Goadby, June 06, 2013, 01:24:31 PM

Previous topic - Next topic

David Goadby

My A10s Debian is the standard purchased SD card. The system boots ok although first boot took quite a while - patience was rewarded! I then wanted to add and update packages and then the problems started..

It's difficult to say exactly what the problem is but adding packages such as joe and aptitude has failed with conflict messages. Recommendations to run -f (force) didn't work. There were a couple of segmentation errors too. The most prominent error was an error referring to GLibc which occurs when trying to install aptitude.

Strangely everything else seems to work fine; it's just the package updates that fail.

Since no one else has reported apt-get errors do I have a bad SD card perhaps? If I do then is there a way of rebuilding the package system from scratch?

Until a downloadable Debian image is available I cannot easily refresh the card other than with a copy of the original. If that is damaged then I might just be wasting my time!

Update 07/06/2013

Just to be sure I tried another power supply. My power supply is rated to 2A and the board only draws an average of 0.35A.

I don't have any (10) rated SD cards to hand so I have tried a number of (4) rated SD cards to try and progress this problem. Here are the typical problems:

* Odd crashes and segmentation errors during apt-get install, apt-get- upgrade, apt-get update.
* By running apt-get upgrade repeatedly it slowly progresses so the problems do not seem to be related to any one package.
* Occasionally the joe editor just dies.
* A couple of SIGABRT errors when running Aptitude.
* After problems the system stops booting Debian and boots Android instead. The SD card has to be reloaded and is then ok for while.
* I suspect that the SD card is getting corrupted.
* Android boots are variable too. Sometimes it hangs showing the silver Android logo. Sometimes I briefly see a yellow background Android screen.

If others are not getting similar problems then I'm starting to think that my A10s has a problem.

Update 10/06/2013. I have ordered another board and SD card to try and isolate the cause. As no similar reports I suspect the hardware. I will update with my findings.

David Goadby


David Goadby

I have been up to my neck recently so haven't had time to resolve this yet. However, I now have fresh SD cards with up-to-date images loaded and another A10S on the bench. I expect to run some tests tomorrow (Thu 27th) and I will report back my findings.

David Goadby