February 28, 2024, 08:45:59 PM

AVR-ISP-MK2 can not read target

Started by fbartra, December 14, 2023, 04:29:14 PM

Previous topic - Next topic

fbartra

I just bought the AVR-ISP-MK2 programmer from Mouser
unfortunately it can not communicate with the target
Software = Atmel Studio 7
Microcontroller: ATMEGA32, replaced the IC already, made no difference.
PCB target: custom but it was programmed before buy seller.
Vcc = 5V --> it reads 3.3V
comm clock = 125KHZ, but I tried different speeds

does any one has a suggestion?

thank you

Fausto Bartra

LubOlimex

Some more details will help us point in right direction:

1. What exactly happens - what is the error message printed?

2. What software tool are you using with AVR-ISP-MK2?

3. What operating system are you using and how is AVR-ISP-MK2 recognized by the operating system?

4. Are you aware that AVR-ISP-MK2 has only 10-pin ISP connector (NO 6-pin ISP connector). If your targets have 6-pin ISP you need to make the proper connections (using wires or adapter).

> Vcc = 5V --> it reads 3.3V

This is not a sign of an issue. It is mentioned at the bottom of the manual:

Q4: I have your AVR-ISP-MKII programmer and it works OK but in Atmel Studio it shows that the target voltage is 3.3V, when I'm sure the board gets 5.0V. What is wrong?

A4: Olimex AVR-ISP-MK2 cannot detect the target voltage! The information about the voltage in Atmel Studio is just a place holder – it shouldn't be taken as a correct reading!
Technical support and documentation manager at Olimex

fbartra

Thank you for your reply, see below my comments

1.- "failed to enter programming mode. ispENterProgMode: Error status received:
Got 0xC0, expected 0x00(command has failed to execute on the tool)

Unable to enter programming mode. Verify device selection, interface settings, target power, security bit, and connections to the target device."

2.- Atmel Studio 7
3.- Windows 10
4.- this one came also 6 pin cable. as shown in the first page of the manual.

note: is there a way to add attachments to replies or paste images?

Any help will be appreciated.

Thank you

Fausto Bartra

fbartra

Dear Olimex:

Fixed the problem.
I connected the programmer as indicated in page 22 0f the users manual
from 10 pin connector to target.

Thank you

Fausto Bartra

LubOlimex

Thank you for the update, glad you got it working.
Technical support and documentation manager at Olimex