booting olinuxino-MICRO first time

Started by nidalpres, October 08, 2012, 05:15:13 AM

Previous topic - Next topic


So I've got my olinuxino MICRO board from Mouser and was eager to hook it up and see what it does.
I've got my SD card (4GB, couldn't find smaller), 5V/4A supply, and composite video cable.

Then I went to order SD card from Olimex site but it appears that card is 10eur and shipping to Canada is 60eur. Oh well, that is leading nowhere.

On to another trail, I went through manual and all links from here to see what I've got, downloaded rootfs and kernel image from links in here, created SD card as instructed, plugged everything in and all I've got was green PWR LED on.

Then I downloaded rootfs and kernel image from archlinux website ( and this time TV screen went from black to deep grey. Small progress.

Then I hooked debug UART pins to serial port (using necessary electronic middleware) and tried all combinations of baud speeds with both kernel from archlinux and one from the link Olimex MICRO product page.

Still nothing.

My question is:
Can someone provide instructions how to connect MICRO board out of the box and what to expect to see to be sure everything is working?

What I have in mind is something along the lines of:
"Connect composite cable, connect power, wait for green led to light on, then connect usb serial f cable. Configure your serial terminal software to 9600,8,N,1 and connect to serial port. Press reset button on the board and you should see kernel boot up messages. If controller has started green led should be on, if kernel is booted yellow led should be on..." etc. etc. a standard dry engineering instructions...

Just some basic quick start stuff which, if you follow by letter, should give you a live system. Once you are sure system is up and running the way manufacturer has intended it to, then you start hacking  :D
And you always have a reference quick start procedure and parameters you can check your work against to see if you are the one who messed up. Or maybe board has finally released misterious blue smoke and now rests in electroinc heaven, together with all other boards I toasted.

Maybe I don't see some obvious stuff? It woudln't be the first time   :)



serial console is at 115200 bps not 9600
please connect cable and see what messages you got there


Quote from: nidalpres on October 08, 2012, 05:15:13 AM
Then I hooked debug UART pins to serial port (using necessary electronic middleware) and tried all combinations of baud speeds with both kernel from archlinux and one from the link Olimex MICRO product page.

What would that "necessary electronic middleware" be ? Something like the PL2303 based USB-Serial (RS232-TTL) converters ? Are you sure that your middleware is working fine, s.a. with another device ?


"necessary electronic middleware" is 3.3V->RS232 voltage level shifter plus PL2303 usb-to-serial converter. This works fine, I'm using it all the time and have tried it with one of the EmbeddedArtists dev boards I have right now. Just in case, I also tried reversing Tx and Rx, it is common source of communication problems when you have too many wires hanging around.

Anyway, that "middleware" works and I have also tried with 115200 bps to no avail.

I wanted quick start for the board just to see it in action.

But it is not a big deal, 9 times out of 10, on any board, I have to go low level and start with reading controller datasheet and measuring voltages on board to see why it doesn't work right away. It looks like this one will also take usual couple of days to figure out what is the reason for it giving out just faint signs of life.

To Olimex: great design and choice of SoC, I'm really excited to put it into action and see what it can do.



OK, I've managed to find bits and pieces on the net today and compiled few bootlets for iMX23 and managed to get error codes on serial console. It's alive! Then I gave another shot to TV_Console_FS from here and, voila!, I've got full bootup! Yesssss! Haven't tried it on TV yet, it works over serial line and that is enough for now, I can play with it.

I'm not sure what was the issue with first attempts, most probably loose wires or not so good connectors.

Bottom line is: if you see green LED light up, that means olinuxino is booting and your SD card is OK. Manual says that LED should start to blink which does not happen, at least not with TV_Console_FS.tgz rootfs, it is missing /home/root/test/led_blink script.

Page 21 of olinuxino MICRO manual revision H says that LED1 starts to blink on successful bootup, my suggestion would be to also put in there that if LED is constantly on, you know that at least initial boot is done, board and SD card are OK and problem might be somewhere else (maybe in some troubleshooting section?).

Really nice board.