msp430-jtag-iso can not set up driver win10 windows 7. Topic does not help.

Started by mic537, February 22, 2020, 07:58:44 AM

Previous topic - Next topic


When I connect MSP430-JTAG-ISO I get it as USB Serial Port ( COM4)
OLIMEX MSP GUI pogramm does not see programmer. ( dlls all from driver)

I tried to install drivers as you described it on one of posts for windows10 but
did not get success. That is my way:

Driver:  OLIMEX MSP430-DLL drivers 1.042

Remove protect against unsigned drivers. That is OK.

Next steps I get only problems:

1. In Select device manually no Olimex producer

2. When I press "Have a disk"
and choose manually olimex_jtags.inf
There is no MSP430-JTAG-ISO in the list:

3 When I choose MSP JTAG TINY from list and try to set up driver
I got blue screen and Windows Error.
I tried all variants from list and in all got Windows blue screen.

win10 -64, win7 -64 , win7 -32
In all the same result.

But one positive result came, the Olimex producer started to appear in
list of devices:

When I try to install MSP OLIMEX Tiny from list I get blue screen on windows 7
and windows 10 sometimes says  "Style of INF is different than was  requested":

When I try to update driver for USB Serial port by choosing folder Driver,
it says that up to date driver already installed.

What to do?


I see you have approached the problem properly.  Looking at olimex_jtag.inf I see no mention of MSP430-JTAG-ISO. Instead of the inf in the main folder, try to use the inf files in folder "64bit" - "ftdiport.inf" and "ftdibus.inf". These seem to have it mentioned.

Maybe also try the drivers from the previous release. Use the drivers from the "Drivers" folder here:

If these drivers work, still use the DLLs from the newer archive (1.042).

Notice that you if you change the USB port used for MSP430-JTAG-ISO you would need to again disable the driver signature enforcement and install the driver.
Technical support and documentation manager at Olimex


I shuffled all possible variants from both folders ( v 1.042, v1.039) No positive results. If I choose folder Driver - they say: driver up to date, If I dig into devices, olimex, inf file there were not MSP430-JTAG-ISO in them, only rfjtag or msp tiny or others. After many hours of experiments I "gained" to situation when my Windows crashs any time I insert usb to jtag. Finita la comedy! I've got only one idea that Russians hackers not only influenced Trump's election but spoiled these drivers too. Other ideas?


Can you try with this inf: ?

It is the one from the latest version but I added the name, VID and PID of the ISO programmer.

It requires disabling the signature enforcement.
Technical support and documentation manager at Olimex