Kernel 3.6 ethernet configuration

Started by marcellus.pereira, October 02, 2012, 03:21:42 am

Previous topic - Next topic

marcellus.pereira

Dear ALL,

I built a kernel for imx233, but I can't get the ethernet running... can anyone help? My .config file is the following:

http://sdrv.ms/PIoc3C


Thank you very much!

marcellus.pereira

Well, since I could not find the SMSC_95XX option under 'make menuconfig', I tried manually to compile the module. But that's what I get after the insmod:

# insmod /mnt/linux_freescale/smsc95xx.ko
[   35.200000] smsc95xx: Unknown symbol usbnet_set_msglevel (err 0)
[   35.200000] smsc95xx: Unknown symbol usbnet_change_mtu (err 0)
[   35.210000] smsc95xx: Unknown symbol usbnet_get_msglevel (err 0)
[   35.220000] smsc95xx: Unknown symbol usbnet_open (err 0)
[   35.230000] smsc95xx: Unknown symbol usbnet_skb_return (err 0)
[   35.230000] smsc95xx: Unknown symbol usbnet_tx_timeout (err 0)
[   35.240000] smsc95xx: Unknown symbol usbnet_get_settings (err 0)
[   35.250000] smsc95xx: Unknown symbol usbnet_get_link (err 0)
[   35.250000] smsc95xx: Unknown symbol usbnet_suspend (err 0)
[   35.260000] smsc95xx: Unknown symbol usbnet_start_xmit (err 0)
[   35.270000] smsc95xx: Unknown symbol usbnet_get_drvinfo (err 0)
[   35.280000] smsc95xx: Unknown symbol usbnet_get_endpoints (err 0)
[   35.280000] smsc95xx: Unknown symbol usbnet_nway_reset (err 0)
[   35.290000] smsc95xx: Unknown symbol usbnet_stop (err 0)
[   35.300000] smsc95xx: Unknown symbol usbnet_defer_kevent (err 0)
[   35.310000] smsc95xx: Unknown symbol usbnet_disconnect (err 0)
[   35.310000] smsc95xx: Unknown symbol usbnet_set_settings (err 0)
[   35.320000] smsc95xx: Unknown symbol usbnet_probe (err 0)
[   35.330000] smsc95xx: Unknown symbol usbnet_resume (err 0)
insmod: can't insert '/mnt/linux_freescale/smsc95xx.ko': unknown symbol in module, or unknown parameter

Any ideas?

Thank you very much.

marcellus.pereira

Well, it's seems to be solved.

The fact is the configuration is "hidden". To anyone in the future with the same problem, you must activate the Device/Drivers -> Network Device Support -> USB Network Adapters -> Multi-purpose USB Networking Framework -> SMSC LAN95XX based USB 2.0 10/100 ethernet devices.