Olimex Support Forum

OLinuXino Android / Linux boards and System On Modules => A13 => Topic started by: thom_nic on May 17, 2022, 07:23:58 pm

Title: `openssl speed` causes reset on a13-som-512 during SHA1 hash
Post by: thom_nic on May 17, 2022, 07:23:58 pm
I'm using stock image A13-OLinuXino-bullseye-minimal-20220321-223544.img.7z

If I run `openssl speed` I repeatedly get a hard reset during sha1 hashes.  There is no panic or core dump printed to the console.  What could be causing this??

root@a13-olinuxino:~# openssl speed
Doing md4 for 3s on 16 size blocks: 1476413 md4's in 2.99s
Doing md4 for 3s on 64 size blocks: 1334622 md4's in 2.98s
Doing md4 for 3s on 256 size blocks: 985821 md4's in 2.99s
Doing md4 for 3s on 1024 size blocks: 478877 md4's in 2.99s
Doing md4 for 3s on 8192 size blocks: 83154 md4's in 2.99s
Doing md4 for 3s on 16384 size blocks: 42717 md4's in 2.99s
Doing md5 for 3s on 16 size blocks: 3318769 md5's in 2.99s
Doing md5 for 3s on 64 size blocks: 2292401 md5's in 2.95s
Doing md5 for 3s on 256 size blocks: 1235315 md5's in 3.00s
Doing md5 for 3s on 1024 size blocks: 430949 md5's in 2.99s
Doing md5 for 3s on 8192 size blocks: 60970 md5's in 2.99s
Doing md5 for 3s on 16384 size blocks: 30754 md5's in 3.00s
Doing hmac(md5) for 3s on 16 size blocks: 1182026 hmac(md5)'s in 2.99s
Doing hmac(md5) for 3s on 64 size blocks: 1002422 hmac(md5)'s in 2.99s
Doing hmac(md5) for 3s on 256 size blocks: 728702 hmac(md5)'s in 2.99s
Doing hmac(md5) for 3s on 1024 size blocks: 346668 hmac(md5)'s in 2.99s
Doing hmac(md5) for 3s on 8192 size blocks: 58851 hmac(md5)'s in 2.99s
Doing hmac(md5) for 3s on 16384 size blocks: 29660 hmac(md5)'s in 2.94s
Doing sha1 for 3s on 16 size blocks: 2904146 sha1's in 2.99s
Doing sha1 for 3s on 64 size blocks: 1938359 sha1's in 2.99s
Doing sha1 for 3s on 256 size blocks: 1010132 sha1's in 2.99s
Doing sha1 for 3s on 1024 size blocks: 345871 sha1's in 2.98s
Doing sha1 for 3s on 8192 size blocks:
U-Boot SPL 2021.04+olimex-1-20211223.094223 (Dec 23 2021 - 09:43:25 +0000)
DRAM: 512 MiB
CPU: 1008000000Hz, AXI/AHB/APB: 3/2/2
A13 Board no eeprom found!
 PMIC not found board is A13-SOM-512
Trying to boot from MMC1
(normal boot sequence)

Another instance, it rebooted slightly earlier:
Doing sha1 for 3s on 64 size blocks: 1937679 sha1's in 2.99s
Doing sha1 for 3s on 256 size blocks: 1011186 sha1's in 3.00s
Doing sha1 for 3s on 1024 size blocks:
U-Boot SPL 2021.04+olimex-1-20211223.094223 (Dec 23 2021 - 09:43:25 +0000)
DRAM: 512 MiB
CPU: 1008000000Hz, AXI/AHB/APB: 3/2/2
A13 Board no eeprom found!
Title: Re: `openssl speed` causes reset on a13-som-512 during SHA1 hash
Post by: LubOlimex on May 18, 2022, 11:28:27 am
Looks like either insufficient power supply or overheating to me.

How do you power the board? Where exactly do you apply the power supply? What is the power rating of your power supply?
Title: Re: `openssl speed` causes reset on a13-som-512 during SHA1 hash
Post by: thom_nic on June 17, 2022, 06:33:37 pm
Hey thanks very much for the reply - I didn't get a notification but just happened to check back on this forum because it seems we are indeed seeing high power draw on the board.  I need to gather more information regarding the hardware design.
Title: Re: `openssl speed` causes reset on a13-som-512 during SHA1 hash
Post by: LubOlimex on June 20, 2022, 01:34:12 pm
Well the schematics are here:

https://github.com/OLIMEX/SOM/tree/master/A13/A13-SOM

The big thing about A13-SOM is that it has no PMU, no AXP209.