Olimex Support Forum

ARM => NXP => Topic started by: bkndr on January 21, 2021, 07:53:08 pm

Title: [SOLVED] LPC-P1343 upload binary
Post by: bkndr on January 21, 2021, 07:53:08 pm
Hello,

I have an Olimex LPC-P1343 board. I tried to upload a binary file by closing the JMP BLD_E, deleted the actual firmware.bin and placed my password.bin. I pushed the reset button, disconnected the USB, opened the JMP BLD_E.

The issue I have now is that when I connect the board with USB, no matter the JMP BLD_E is closed or open, the disk is mounted (CRP DISABLD)

I tried to put back the original firmware with no luck :(
Title: Re: LPC-P1343 upload binary
Post by: LubOlimex on January 22, 2021, 09:07:55 am
So the board is always in bootloader mode? Did you test before that if when BLD_E is closed it didn't appear as storage device?
Title: Re: LPC-P1343 upload binary
Post by: bkndr on January 22, 2021, 10:22:31 am
Yes, before to try to change the firmware, I started the board with BLD_E opened. (The 8 light were blinking, button 2 to change the order, button 1 back to the first order)

Then, I accessed to SWD (JTAG, with BLD_E open), just to test and dump the firmware (reset halt first and dump from 0x00000000 to 0x00080000)
Finally, I also tried the UART connection and access to the ISP bootloader.(with PIO0_3 to grnd)
Title: Re: LPC-P1343 upload binary
Post by: LubOlimex on January 22, 2021, 11:04:25 am
Maybe something that you did with the JTAG/SWD affected the operation. If you have JTAG/SWD tool you can re-program the original program.

I've uploaded it here:

ftp://staging.olimex.com/Lub-clients/TEST_bin.zip

The archive contains different binaries of the same software that is programmed to each board here via JTAG/SWD tool.
Title: Re: LPC-P1343 upload binary
Post by: bkndr on January 22, 2021, 11:49:35 am
Thank you, I erased and write the Test.bin and the board is back to normal.

I have a dumb question, what access is needed to view:
B1 Pressed
B1 Released
B2 Pressed
B2 Released

I tried the UART with no success.
Title: Re: LPC-P1343 upload binary
Post by: bkndr on January 23, 2021, 12:11:52 pm
I guess there is something wrong with the original firmware as I should have something on the UART. Anyway, I succeed to create my own firmware and interacted with the UART.

Thanks for your help.