Olimex Support Forum

ARM => ST => Topic started by: poeltla on January 11, 2021, 02:34:26 pm

Title: Arduino Boards Manager does not list Olimex Boards
Post by: poeltla on January 11, 2021, 02:34:26 pm
I am following the STM32-E407 user's manual, CHAPTER 7 HOW TO USE THE BOARD WITH ARDUINO IDE.

After entering the URL https://raw.githubusercontent.com/OLIMEX/Arduino_configurations/master/STM/package_olime
x_stm_index.json in the Preferences, the Boards Manager still does not list any Olimex boards.

What am I doing wrong?
Title: Re: Arduino Boards Manager does not list Olimex Boards
Post by: LubOlimex on January 11, 2021, 02:49:41 pm
You also need to install and update the "Olimex STM32 boards" package from Tools -> Board... -> Boards Manager...

After installing and updating, you would see STM32-E407 and STM32-H407 show up in the board selection.
Title: Re: Arduino Boards Manager does not list Olimex Boards
Post by: poeltla on January 11, 2021, 08:48:03 pm
That's the problem: The Board Manager does not show the Olimex STM32 boards.

Below I typed up exactly what the board managers shows:

Arduino AVR Boards
Arduino megaAVR Boards
Arduino SAM Boards (32-bits ARM Cortex-M3)
Arduino SAMD Boards (32-bits ARM Cortex-M0+)
Arduino SAMD Beta Boards (32-bits ARM Cortex-M0+)
Arduino mbed-enabled Boards
Arduino nRF52 Boards
[DEPRECATED] Arduino mbed-enabled Boards
Intel i586 Boards
Intel i686 Boards
Intel Curie Boards
Atmel AVR Xplained-minis
littleBits Arduino AVR Modules
Windows 10 Iot Core
Arrow Boards
EMORO 2560
Industruino SAMD Boards (32-bits ARM Cortex-M0+)

An that's all.

Title: Re: Arduino Boards Manager does not list Olimex Boards
Post by: poeltla on January 11, 2021, 08:58:08 pm
I works now. I copied the URL first from the manual into my browser and made sure a JSON file was returned. Then I copied the URL from my browser into the Preferences of Arduino and made sure no %20 or line breaks were introduced.
Title: Re: Arduino Boards Manager does not list Olimex Boards
Post by: LubOlimex on January 12, 2021, 08:31:55 am
Thanks for the update. Glad this got solved.