Olimex Support Forum

Others => FPGA => Topic started by: joy.nag on August 27, 2020, 03:30:24 pm

Title: Problems programming iCE40HX8K-EVB with OLIMEXINO-32U4
Post by: joy.nag on August 27, 2020, 03:30:24 pm

I'm having some trouble trying to program the iCE40HX8K-EVB with the OLIMEXINO-32U4.

I am programmed OLIMEXINO-32U4 to work as a programmer for iCE40HX8K-EVB which was successful from Arduino Studio.

I also tried loading https://www.olimex.com/Products/Duino/AVR/OLIMEXINO-32U4/resources/OLIMEXINO-32U4(Leonardo)_button_example.zip into OLIMEXINO-32U4 and it worked as expected.

But then I tried to load leds example using `iceprogduino`, which seemed to have succeeded but pressing the buttons on iCE40HX8K-EVB afterwards didn't work as expected.

When running

iceprogduino -I/dev/cu.usbmodem14101 -v hardware.bin

I saw this error

Serial: /dev/cu.usbmodem14101: Undefined error: 0
Manufacturer ID: 0xC8- W25Q16BV
prog 0x000000 +0x100..
...........prog 0x000100 +0x100..
.prog 0x000200 +0x100..
.prog 0x000300 +0x100..
.prog 0x000400 +0x100..
.prog 0x000500 +0x100..
.prog 0x000600 +0x100..
.prog 0x000700 +0x100..
.prog 0x000800 +0x100..
.prog 0x000900 +0x100..

But then it seemed the programming succeeded, I also saw the green led on the iCE40HX8K-EVB when iceprogduino finished.

I have tried different combinations of setup using your guides and all but nothing seems to be working. I can't get the buttons to work with the leds, I don't know if there's any other way of verifying if the programming from OLIMEXINO-32U4 is actually working.

My primary operating system is OSX, but I also tried the setup from Ubuntu from inside virtual box with no success. I followed the steps from this tutorial: https://www.olimex.com/wiki/ICE40HX1K-EVB#Installing_Icestorm_FOSS_tools_for_iCE40

What else would you suggest trying?
Title: Re: Problems programming iCE40HX8K-EVB with OLIMEXINO-32U4
Post by: LubOlimex on August 27, 2020, 04:40:43 pm
So the original blink example upload successfully and works fine?